jas_utils 1.0.0-dev.2 icon indicating copy to clipboard operation
jas_utils: ^1.0.0-dev.2 copied to clipboard

Utils for jack a service projects

0
likes
90/ 130
pub points
0%
popularity

We analyzed this package 9 hours ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 107 out of 2424 API elements (4.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:jas_utils/jas_utils.dart that imports:
  • package:jas_utils/src/ui/web_elements/text.dart that imports:
  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:jas_utils/jas_utils.dart that imports:
  • package:jas_utils/src/ui/web_elements/text.dart that imports:
  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:jas_utils/jas_utils.dart that imports:
  • package:jas_utils/src/ui/web_elements/text.dart that imports:
  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:jas_utils/jas_utils.dart that imports:
  • package:jas_utils/src/ui/web_elements/text.dart that imports:
  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock/wakelock.dart that imports:
  • package:wakelock_macos/wakelock_macos.dart that declares support for platforms: macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:jas_utils/jas_utils.dart that imports:
  • package:jas_utils/src/ui/web_elements/text.dart that imports:
  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:flutter_html/src/widgets/iframe_mobile.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:jas_utils/jas_utils.dart that imports:
  • package:jas_utils/src/ui/web_elements/text.dart that imports:
  • package:flutter_html/flutter_html.dart that imports:
  • package:flutter_html/src/replaced_element.dart that imports:
  • package:flutter_html/src/widgets/iframe_mobile.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_android_cookie_manager.dart that declares support for platforms: Android.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 179 issues. Showing the first 2:

INFO: Duplicate import.

lib/src/model/address.dart:6:8

  ╷
6 │ import 'package:geolocator/geolocator.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/model/address.dart

INFO: The import of 'db_transfer.dart' is unnecessary because all of the used elements are also provided by the import of '../../jas_utils.dart'.

lib/src/model/app_settings.dart:10:8

   ╷
10 │ import 'db_transfer.dart';
   │        ^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/model/app_settings.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^3.1.63.3.13.3.1
cached_network_image^3.1.03.2.13.2.1
cloud_firestore^3.1.13.2.03.4.5
csv^5.0.05.0.15.0.1
firebase_auth^3.2.03.4.03.6.4
firebase_core^1.10.01.19.01.21.0
firebase_messaging^11.2.511.4.312.0.3
firebase_storage^10.1.010.3.010.3.6
flutterflutter0.0.00.0.0
flutter_app_badger^1.3.01.4.01.4.0
flutter_facebook_auth^3.5.63.5.74.4.1
flutter_html^2.2.12.2.12.2.1
flutter_paystack^1.0.5+11.0.5+11.0.5+1
flutter_stripe^2.0.12.5.04.0.0
geolocator^8.0.18.2.19.0.1
google_maps_flutter^2.0.32.1.122.1.12
google_maps_webservice^0.0.20-nullsafety.50.0.20-nullsafety.50.0.20-nullsafety.5
google_sign_in^5.2.15.4.15.4.1
google_sign_in_web^0.10.0+30.10.20.10.2
http^0.13.40.13.50.13.5
http_auth^1.0.11.0.11.0.1
intl^0.17.00.17.00.17.0
js^0.6.30.6.40.6.4
maps_toolkit^2.0.02.0.12.0.1
path_provider^2.0.72.0.112.0.11
pdf^3.6.43.6.43.8.2
qr_flutter^4.0.04.0.04.0.0
razorpay_flutter_31^1.2.81.3.21.3.2
sign_in_with_apple^3.0.03.3.04.1.0
timeago^3.1.03.3.03.3.0
universal_html^2.0.82.0.82.0.8
url_launcher^6.0.136.1.56.1.5
uuid^3.0.53.0.63.0.6
webview_flutter^2.3.02.8.03.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
barcode-2.1.02.2.2
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
characters-1.2.01.2.1
charcode-1.3.11.3.1
chewie-1.3.41.3.4
chewie_audio-1.3.01.3.0
clock-1.1.11.1.1
cloud_firestore_platform_interface-5.7.25.7.2
cloud_firestore_web-2.6.182.8.5
collection-1.16.01.16.0
convert-3.0.23.0.2
crypto-3.0.23.0.2
csslib-0.17.20.17.2
cupertino_icons-1.0.51.0.5
eventify-1.0.11.0.1
ffi-2.0.12.0.1
file-6.1.46.1.4
firebase_auth_platform_interface-6.5.46.5.4
firebase_auth_web-3.3.184.2.4
firebase_core_platform_interface-4.4.14.5.0
firebase_core_web-1.6.51.7.1
firebase_messaging_platform_interface-3.5.44.1.2
firebase_messaging_web-2.4.33.1.2
firebase_storage_platform_interface-4.1.144.1.14
firebase_storage_web-3.2.183.3.4
flutter_blurhash-0.7.00.7.0
flutter_cache_manager-3.3.03.3.0
flutter_facebook_auth_platform_interface-2.7.14.0.1
flutter_facebook_auth_web-2.6.0+24.0.1
flutter_layout_grid-1.0.62.0.1
flutter_math_fork-0.5.00.6.3+1
flutter_plugin_android_lifecycle-2.0.72.0.7
flutter_svg-0.23.0+11.1.4
flutter_web_plugins-0.0.00.0.0
freezed_annotation-2.1.02.1.0
geolocator_android-3.2.14.1.0
geolocator_apple-2.2.12.2.1
geolocator_platform_interface-4.0.64.0.6
geolocator_web-2.1.62.1.6
geolocator_windows-0.1.10.1.1
google_maps_flutter_android-2.1.102.1.10
google_maps_flutter_ios-2.1.112.1.11
google_maps_flutter_platform_interface-2.2.22.2.2
google_sign_in_android-6.0.16.0.1
google_sign_in_ios-5.4.05.4.0
google_sign_in_platform_interface-2.2.02.2.0
html-0.15.00.15.0
http_parser-4.0.14.0.1
image-3.1.33.2.0
json_annotation-4.6.04.6.0
matcher-0.12.120.12.12
material_color_utilities-0.1.40.2.0
meta-1.7.01.8.0
nested-1.0.01.0.0
numerus-1.1.12.0.0
octo_image-1.0.21.0.2
path-1.8.21.8.2
path_drawing-0.5.1+11.0.1
path_parsing-0.2.11.0.1
path_provider_android-2.0.192.0.19
path_provider_ios-2.0.112.0.11
path_provider_linux-2.1.72.1.7
path_provider_macos-2.0.62.0.6
path_provider_platform_interface-2.0.42.0.4
path_provider_windows-2.1.22.1.2
pedantic-1.11.11.11.1
petitparser-5.0.05.0.0
platform-3.1.03.1.0
plugin_platform_interface-2.1.22.1.2
process-4.2.44.2.4
provider-6.0.36.0.3
qr-2.1.03.0.1
quiver-3.1.03.1.0
rxdart-0.27.50.27.5
sign_in_with_apple_platform_interface-1.0.01.0.0
sign_in_with_apple_web-1.0.11.0.1
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
sqflite-2.0.3+12.0.3+1
sqflite_common-2.2.1+12.2.1+1
stack_trace-1.10.01.10.0
stream_transform-2.0.02.0.0
string_scanner-1.1.11.1.1
stripe_android-2.5.04.0.0
stripe_ios-2.5.04.0.0
stripe_platform_interface-2.5.0+14.0.0
synchronized-3.0.0+23.0.0+2
term_glyph-1.2.11.2.1
tuple-2.0.02.0.0
typed_data-1.3.11.3.1
universal_io-2.0.42.0.4
url_launcher_android-6.0.176.0.17
url_launcher_ios-6.0.176.0.17
url_launcher_linux-3.0.13.0.1
url_launcher_macos-3.0.13.0.1
url_launcher_platform_interface-2.1.02.1.0
url_launcher_web-2.0.132.0.13
url_launcher_windows-3.0.13.0.1
vector_math-2.1.22.1.3
video_player-2.4.62.4.6
video_player_android-2.3.92.3.9
video_player_avfoundation-2.3.52.3.5
video_player_platform_interface-5.1.45.1.4
video_player_web-2.0.122.0.12
wakelock-0.6.20.6.2
wakelock_macos-0.4.00.4.0
wakelock_platform_interface-0.3.00.3.0
wakelock_web-0.4.00.4.0
wakelock_windows-0.2.00.2.0
webview_flutter_android-2.9.52.9.5
webview_flutter_platform_interface-1.9.21.9.2
webview_flutter_wkwebview-2.9.32.9.3
win32-2.7.02.7.0
xdg_directories-0.2.0+10.2.0+1
xml-5.4.16.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^11.2.5` on firebase_messaging does not support the stable version `12.0.0`.

Try running dart pub upgrade --major-versions firebase_messaging to update the constraint.

The constraint `^3.5.6` on flutter_facebook_auth does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions flutter_facebook_auth to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.15, Flutter 3.0.5, Dart 2.17.6.