html 0.14.0+3

  • Readme
  • Changelog
  • Installing
  • 97

This is a pure Dart HTML5 parser. It's a port of html5lib from Python.

Usage #

Parsing HTML is easy!

import 'package:html/parser.dart' show parse;
import 'package:html/dom.dart';

main() {
  var document = parse(
      '<body>Hello world! <a href="www.html5rocks.com">HTML5 rocks!');
  print(document.outerHtml);
}

You can pass a String or list of bytes to parse. There's also parseFragment for parsing a document fragment, and HtmlParser if you want more low level control.

0.14.0+3 #

  • Fix spans generated for HTML with higher-plane unicode characters (eg. emojis).

0.14.0+2 #

  • Support package:css >=0.13.2 <0.17.0.

0.14.0+1 #

  • Support package:css >=0.13.2 <0.16.0.

0.14.0 #

BREAKING CHANGES

  • Drop support for encodings other than UTF-8 and ASCII.
  • Removed parser_console.dart library.

0.13.4+1 #

  • Fixes to readme and pubspec.

0.13.4 #

  • Require Dart 2.0 stable.

0.13.3+3 #

  • Do not use this tag in our systems - there was an earlier version of it pointing to a different commit, that is still in some caches.

  • Fix missing_return analyzer errors in processStartTag and processEndTag methods.

0.13.3+2 #

  • Set max SDK version to <3.0.0, and adjust other dependencies.

0.13.3+1 #

  • Updated SDK version to 2.0.0-dev.17.0

0.13.3 #

  • Update the signatures of FilteredElementList.indexOf and FilteredElementList.lastIndexOf to include type annotations.

0.13.2+2 #

  • Update signature for implementations of Iterable.singleWhere to include optional argument.

0.13.2+1 #

  • Changed the implementation of Set and List classes to use base classes from dart:collection.

0.13.2 #

  • Support the latest release of pkg/csslib.

0.13.1 #

  • Update Set.difference to take a Set

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  html: ^0.14.0+3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:html/dom.dart';
import 'package:html/dom_parsing.dart';
import 'package:html/parser.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
99
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
97
Learn more about scoring.

We analyzed this package on Nov 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and html.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
csslib >=0.13.2 <0.17.0 0.16.1
source_span >=1.0.0 <2.0.0 1.5.5
Transitive dependencies
charcode 1.1.2
term_glyph 1.1.0
Dev dependencies
path ^1.6.2 1.6.4
pedantic ^1.3.0
test ^1.3.0