http_parser 3.1.4

Dart native js
Flutter Android iOS web

A platform-independent package for parsing and serializing HTTP formats.

Pub Package Build Status

http_parser is a platform-independent package for parsing and serializing various HTTP-related formats. It's designed to be usable on both the browser and the server, and thus avoids referencing any types from dart:io or dart:html. It includes:

  • Support for parsing and formatting dates according to HTTP/1.1, the HTTP/1.1 standard.

  • A MediaType class that represents an HTTP media type, as used in Accept and Content-Type headers. This class supports both parsing and formatting media types according to HTTP/1.1.

  • A WebSocketChannel class that provides a StreamChannel interface for both the client and server sides of the WebSocket protocol independently of any specific server implementation.

23
likes
110
pub points
100%
popularity

A platform-independent package for parsing and serializing HTTP formats.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

nweiz@google.com
kevmoo@google.com

License

BSD (LICENSE)

Dependencies

charcode, collection, source_span, string_scanner, typed_data

More

Packages that depend on http_parser