url_launcher_macos 0.0.1+2

  • Readme
  • Changelog
  • Example
  • Installing
  • 92

url_launcher_macos #

The macos implementation of url_launcher.

Usage #

Import the package #

This package has been endorsed, meaning that you only need to add url_launcher as a dependency in your pubspec.yaml. It will be automatically included in your app when you depend on package:url_launcher.

This is what the above means to your pubspec.yaml:

...
dependencies:
  ...
  url_launcher: ^5.4.1
  ...

If you wish to use the macos package only, you can add url_launcher_macos as a dependency:

...
dependencies:
  ...
  url_launcher_macos: ^0.0.1
  ...

0.0.1+2 #

  • Update README.

0.0.1+1 #

  • Add an android/ folder with no-op implementation to workaround https://

0.0.1 #

  • Initial open source release.

example/README.md

url_launcher_example #

Demonstrates how to use the url_launcher plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  url_launcher_macos: ^0.0.1+2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:url_launcher_macos/url_launcher_macos.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
94
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
78
Overall:
Weighted score of the above. [more]
92
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health issues and suggestions

Document public APIs. (-1 points)

1 out of 1 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8