video_player_web 0.1.1+1

  • Readme
  • Changelog
  • Installing
  • new70

video_player_web #

The web implementation of video_player.

Usage #

To use this plugin in your Flutter Web app, simply add it as a dependency in your pubspec using a git dependency. This is only temporary: in the future we hope to make this package an "endorsed" implementation of video_player, so that it is automatically included in your Flutter Web app when you depend on package:video_player.

dependencies:
  video_player: ^0.10.4
  video_player_web:
    git:
      url: git://github.com/flutter/plugins.git
      path: packages/video_player/video_player_web

Once you have the video_player_web dependency in your pubspec, you should be able to use package:video_player as normal.

Autoplay #

Playing videos without prior interaction with the site might be prohibited by the browser and lead to runtime errors. See also: https://goo.gl/xX8pDD.

0.1.1+1 #

0.1.1 #

  • Support videos from assets.

0.1.0+1 #

  • Remove the deprecated author: field from pubspec.yaml
  • Require Flutter SDK 1.10.0 or greater.

0.1.0 #

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  video_player_web: ^0.1.1+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:video_player_web/video_player_web.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
73
Health:
Code health derived from static analysis. [more]
75
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
53
Overall:
Weighted score of the above. [more]
70
Learn more about scoring.

We analyzed this package on Dec 12, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.1+4
  • Flutter: 1.12.13+hotfix.4

Health issues and suggestions

Fix platform conflict in lib/video_player_web.dart. (-25 points)

Make sure that the imported libraries are not in conflict. Detected components: flutter, html, io, isolate.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

References Flutter, but has conflicting libraries: package:video_player_web/video_player_web.dart (components: flutter, html, io, isolate).

The package description is too short. (-17 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and video_player_web.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
flutter_web_plugins 0.0.0
meta ^1.1.7 1.1.8
video_player_platform_interface ^1.0.0 1.0.4
Transitive dependencies
collection 1.14.11 1.14.12
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
video_player