cupertino_icons 0.1.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 92

Cupertino Icons #

This is an asset repo containing the default set of icon assets used by Flutter's Cupertino widgets.

Issues #

For issues, file directly in the main Flutter repo.

Icons #

image map of glyphs

0.1.2 #

  • Fix linter warning for missing lib/ folder.
  • Constrain to Dart 2.

0.1.1 #

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cupertino_icons: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.1.2 Apr 5, 2018 Go to the documentation of cupertino_icons 0.1.2 Download cupertino_icons 0.1.2 archive
0.1.1 Sep 19, 2017 Go to the documentation of cupertino_icons 0.1.1 Download cupertino_icons 0.1.1 archive
0.1.0 Sep 18, 2017 Go to the documentation of cupertino_icons 0.1.0 Download cupertino_icons 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
100
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
61
Overall:
Weighted score of the above. [more]
92
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is getting outdated. (-20 points)

The package was last published 62 weeks ago.

The package description is too short. (-19 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0