iconnexz 1.0.2+1 icon indicating copy to clipboard operation
iconnexz: ^1.0.2+1 copied to clipboard

A new Flutter project.

0
likes
60/ 130
pub points
0%
popularity

We analyzed this package 29 hours ago, and awarded it 60 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 157 out of 1477 API elements (10.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform Support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:iconnexz/API/api.dart that imports:
  • package:iconnexz/main.dart that imports:
  • package:iconnexz/VendorDashboard/main_screen.dart that imports:
  • package:iconnexz/VendorLandingPage/VendorLandingPage.dart that imports:
  • package:iconnexz/VendorLandingPage/VendorBody.dart that imports:
  • package:iconnexz/VendorLandingPage/chewie_list_item.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock/wakelock.dart that imports:
  • package:wakelock_macos/wakelock_macos.dart that declares support for platforms: macOS.
Package does not support platform `iOS`.

Because:

  • package:iconnexz/API/api.dart that imports:
  • package:iconnexz/main.dart that imports:
  • package:iconnexz/VendorDashboard/main_screen.dart that imports:
  • package:iconnexz/VendorLandingPage/VendorLandingPage.dart that imports:
  • package:iconnexz/VendorLandingPage/VendorBody.dart that imports:
  • package:iconnexz/VendorLandingPage/chewie_list_item.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock/wakelock.dart that imports:
  • package:wakelock_macos/wakelock_macos.dart that declares support for platforms: macOS.
Package does not support platform `Windows`.

Because:

  • package:iconnexz/API/api.dart that imports:
  • package:iconnexz/main.dart that imports:
  • package:iconnexz/VendorDashboard/main_screen.dart that imports:
  • package:iconnexz/VendorLandingPage/VendorLandingPage.dart that imports:
  • package:iconnexz/widgets/navigation_drawer/navigation_drawer.dart that imports:
  • package:iconnexz/widgets/navigation_drawer/drawer_item2.dart that imports:
  • package:iconnexz/SuggestVendorPage/SuggestVendorPage.dart that imports:
  • package:iconnexz/SuggestVendorPage/SuggestVendorDesktop.dart that imports:
  • package:image_picker/image_picker.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:iconnexz/API/api.dart that imports:
  • package:iconnexz/main.dart that imports:
  • package:iconnexz/VendorDashboard/main_screen.dart that imports:
  • package:iconnexz/VendorLandingPage/VendorLandingPage.dart that imports:
  • package:iconnexz/widgets/navigation_drawer/navigation_drawer.dart that imports:
  • package:iconnexz/widgets/navigation_drawer/drawer_item2.dart that imports:
  • package:iconnexz/SuggestVendorPage/SuggestVendorPage.dart that imports:
  • package:iconnexz/SuggestVendorPage/SuggestVendorDesktop.dart that imports:
  • package:image_picker/image_picker.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:iconnexz/API/api.dart that imports:
  • package:iconnexz/main.dart that imports:
  • package:iconnexz/VendorDashboard/main_screen.dart that imports:
  • package:iconnexz/VendorLandingPage/VendorLandingPage.dart that imports:
  • package:iconnexz/widgets/navigation_drawer/navigation_drawer.dart that imports:
  • package:iconnexz/widgets/navigation_drawer/drawer_item2.dart that imports:
  • package:iconnexz/SuggestVendorPage/SuggestVendorPage.dart that imports:
  • package:iconnexz/SuggestVendorPage/SuggestVendorDesktop.dart that imports:
  • package:image_picker/image_picker.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:iconnexz/API/api.dart that imports:
  • package:iconnexz/main.dart that imports:
  • package:iconnexz/VendorDashboard/main_screen.dart that imports:
  • package:iconnexz/VendorLandingPage/VendorLandingPage.dart that imports:
  • package:iconnexz/VendorLandingPage/VendorBody.dart that imports:
  • package:iconnexz/VendorLandingPage/chewie_list_item.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock/wakelock.dart that imports:
  • package:wakelock_macos/wakelock_macos.dart that declares support for platforms: macOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 81 issues. Showing the first 2:

lib/BBQChickenRicePage/BBQChickenRiceMain.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/BBQChickenRicePage/BBQChickenRiceScreen.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
animate_do^2.0.02.1.02.1.0
auto_size_text^3.0.0-nullsafety.03.0.03.0.0
better_player^0.0.730.0.810.0.81
chewie^1.2.21.2.21.2.2
collapsible_sidebar^2.0.02.0.1+22.0.1+2
cupertino_icons^1.0.21.0.41.0.4
dio^4.0.04.0.44.0.4
dropdown_search^0.6.30.6.32.0.1
file_picker^4.1.34.3.24.3.2
file_selector^0.8.20.8.2+10.8.2+1
flutterflutter0.0.00.0.0
flutter_rating_bar^4.0.04.0.04.0.0
flutter_svg^0.22.00.22.01.0.1
font_awesome_flutter^9.1.09.2.09.2.0
getwidget^2.0.22.0.42.0.4
google_fonts^2.1.02.2.02.2.0
group_radio_button^1.1.01.1.01.1.0
http^0.13.30.13.40.13.4
image_picker^0.7.5+30.7.5+40.8.4+4
intl_phone_field^2.0.12.1.03.0.0
json_annotation^4.0.04.4.04.4.0
libphonenumber^2.0.12.0.22.0.2
one_context^1.1.11.1.11.1.1
provider^5.0.05.0.06.0.2
responsive_builder^0.4.10.4.10.4.1
shared_preferences^2.0.82.0.122.0.12
sizer^2.0.132.0.152.0.15
video_player^2.2.72.2.112.2.11
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
back_button_interceptor-5.0.25.0.2
characters-1.2.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
cross_file-0.3.20.3.2
crypto-3.0.13.0.1
csslib-0.17.10.17.1
ffi-1.1.21.1.2
file-6.1.26.1.2
file_selector_platform_interface-2.0.42.0.4
file_selector_web-0.8.1+30.8.1+3
flutter_plugin_android_lifecycle-2.0.52.0.5
flutter_web_plugins-0.0.00.0.0
flutter_widget_from_html_core-0.8.40.8.4
fwfh_text_style-2.7.22.7.2
html-0.15.00.15.0
http_parser-4.0.04.0.0
image_picker_for_web-2.1.52.1.5
image_picker_platform_interface-2.4.32.4.3
js-0.6.30.6.4
meta-1.7.01.7.0
nested-1.0.01.0.0
path-1.8.11.8.1
path_drawing-0.5.1+11.0.0
path_parsing-0.2.11.0.0
path_provider-2.0.82.0.8
path_provider_android-2.0.112.0.11
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.52.1.5
path_provider_macos-2.0.52.0.5
path_provider_platform_interface-2.0.32.0.3
path_provider_windows-2.0.52.0.5
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
platform-3.1.03.1.0
plugin_platform_interface-2.1.22.1.2
process-4.2.44.2.4
shared_preferences_android-2.0.102.0.10
shared_preferences_ios-2.0.92.0.9
shared_preferences_linux-2.0.42.0.4
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.32.0.3
shared_preferences_windows-2.0.42.0.4
sky_engine-0.0.990.0.99
source_span-1.8.21.8.2
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
universal_io-2.0.42.0.4
vector_math-2.1.12.1.1
video_player_platform_interface-5.0.15.0.1
video_player_web-2.0.62.0.6
visibility_detector-0.2.20.2.2
wakelock-0.5.60.6.0+1
wakelock_macos-0.4.00.4.0
wakelock_platform_interface-0.3.00.3.0
wakelock_web-0.4.00.4.0
wakelock_windows-0.2.00.2.0
win32-2.3.62.3.6
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^0.6.3` on dropdown_search does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions dropdown_search to update the constraint.

The constraint `^0.22.0` on flutter_svg does not support the stable version `0.23.0`.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.5, Flutter 2.8.1, Dart 2.15.1.