shared_preferences_web 0.1.0

  • Readme
  • Changelog
  • Installing
  • new28

shared_preferences_web #

The web implementation of shared_preferences.

Usage #

Import the package #

To use this plugin in your Flutter Web app, simply add it as a dependency in your pubspec.yaml alongside the base shared_preferences plugin.

(This is only temporary: in the future we hope to make this package an "endorsed" implementation of shared_preferences, so that it is automatically included in your Flutter Web app when you depend on package:shared_preferences.)

This is what the above means to your pubspec.yaml:

...
dependencies:
  ...
  shared_preferences: ^0.5.4+8
  shared_preferences_web: ^0.1.0
  ...

Use the plugin #

Once you have the shared_preferences_web dependency in your pubspec, you should be able to use package:shared_preferences as normal.

0.1.0 #

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  shared_preferences_web: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:shared_preferences_web/shared_preferences_web.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
36
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
49
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

We analyzed this package on Dec 3, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter pub upgrade failed with the following output:

ERR: Because shared_preferences_web depends on flutter_web_plugins any from sdk which doesn't exist (could not find package flutter_web_plugins in the Flutter SDK), version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

The package description is too short. (-11 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and shared_preferences_web.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0