flutterflow_ui 0.2.0+1 copy "flutterflow_ui: ^0.2.0+1" to clipboard
flutterflow_ui: ^0.2.0+1 copied to clipboard

Flutter package that makes it easy to use UI widgets and code generated by FlutterFlow in your Flutter projects.

59
likes
110/ 140
pub points
95%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

262 out of 1017 API elements (25.8 %) have documentation comments.

Some symbols that are missing documentation: flutterflow_ui, flutterflow_ui.AnimatedWidgetExtension, flutterflow_ui.AnimatedWidgetExtension.animateOnActionTrigger, flutterflow_ui.AnimatedWidgetExtension.animateOnPageLoad, flutterflow_ui.AnimationInfo.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:flutterflow_ui/flutterflow_ui.dart that imports:
  • package:flutterflow_ui/src/flutter_flow/flutter_flow.dart that imports:
  • package:flutterflow_ui/src/flutter_flow/flutter_flow_rive_controller.dart that imports:
  • package:rive/rive.dart that imports:
  • package:rive/src/widgets/rive_animation.dart that imports:
  • package:rive_common/math.dart that declares support for platforms: Android, iOS, Windows, macOS, Web.
Package not compatible with platform Web

Because:

  • package:flutterflow_ui/flutterflow_ui.dart that imports:
  • package:flutterflow_ui/src/flutter_flow/flutter_flow.dart that imports:
  • package:flutterflow_ui/src/flutter_flow/flutter_flow_util.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: 'useMaterial3' is deprecated and shouldn't be used. Use a ThemeData constructor (.from, .light, or .dark) instead. These constructors all have a useMaterial3 argument, and they set appropriate default values based on its value. See the useMaterial3 API documentation for full details. This feature was deprecated after v3.13.0-0.2.pre.

lib/src/flutter_flow/flutter_flow_icon_button.dart:124:42

    ╷
124 │         data: Theme.of(context).copyWith(useMaterial3: true),
    │                                          ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/flutter_flow/flutter_flow_icon_button.dart

INFO: Use 'TypeName _' instead of a type literal.

lib/src/flutter_flow/flutter_flow_model.dart:153:10

    ╷
153 │     case int:
    │          ^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/flutter_flow/flutter_flow_model.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
auto_size_text 3.0.0 3.0.0 3.0.0
barcode_widget 2.0.3 2.0.3 2.0.4
cached_network_image 3.2.1 3.2.1 3.3.1
carousel_slider 4.2.1 4.2.1 4.2.1
collection any 1.18.0 1.18.0
cupertino_icons ^1.0.0 1.0.8 1.0.8
emoji_flag_converter 1.1.0 1.1.0 1.1.0
equatable 2.0.5 2.0.5 2.0.5
fl_chart 0.55.0 0.55.0 0.67.0
flutter flutter 0.0.0 0.0.0
flutter_animate 4.1.1+1 4.1.1+1 4.5.0
flutter_cache_manager 3.3.0 3.3.0 3.3.1
flutter_credit_card 3.0.6 3.0.6 4.0.1
flutter_plugin_android_lifecycle 2.0.9 2.0.9 2.0.19
flutter_staggered_grid_view 0.6.2 0.6.2 0.7.0
font_awesome_flutter 10.1.0 10.1.0 10.7.0
from_css_color 2.0.0 2.0.0 2.0.0
google_fonts 4.0.3 4.0.3 6.2.1
intl 0.18.1 0.18.1 0.19.0
json_path any 0.7.1 0.7.1
mime_type 1.0.0 1.0.0 1.0.0
page_transition 2.0.4 2.0.4 2.1.0
percent_indicator 4.2.2 4.2.2 4.2.3
provider 6.0.4 6.0.4 6.1.2
rive 0.10.3 0.10.3 0.13.1
rive_common 0.0.6 0.0.6 0.4.5
smooth_page_indicator 1.0.1 1.0.1 1.1.0
sqflite 2.2.6 2.2.6 2.3.3
swipeable_card_stack 0.0.5 0.0.5 0.0.5
table_calendar 3.0.9 3.0.9 3.1.1
timeago 3.2.2 3.2.2 3.6.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
barcode - 2.2.7 2.2.7
cached_network_image_platform_interface - 1.0.0 4.0.0
cached_network_image_web - 1.0.1 1.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
flutter_blurhash - 0.7.0 0.8.2
flutter_web_plugins - 0.0.0 0.0.0
graphs - 2.3.1 2.3.1
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
iregexp - 0.1.2 0.1.2
material_color_utilities - 0.8.0 0.11.1
maybe_just_nothing - 0.5.3 0.5.3
meta - 1.11.0 1.14.0
nested - 1.0.0 1.0.0
octo_image - 1.0.2 2.0.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
pedantic - 1.11.1 1.11.1
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
qr - 3.0.1 3.0.1
rfc_6901 - 0.2.0 0.2.0
rxdart - 0.27.7 0.27.7
simple_gesture_detector - 0.2.1 0.2.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sqflite_common - 2.5.4 2.5.4
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.4.0
vector_math - 2.1.4 2.1.4
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 20 issues. Showing the first 2:

The constraint `2.0.3` on barcode_widget does not support the stable version `2.0.4`.

Try running dart pub upgrade --major-versions barcode_widget to update the constraint.

The constraint `3.2.1` on cached_network_image does not support the stable version `3.2.2`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.