fl_chart 0.0.8

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new86

FL Chart #

pub package APK

FL Chart Logo

💥 A library to draw fantastic charts in Flutter 💥

Chart Types #

LineChartBarChartPieChart
Read MoreRead MoreRead More

Banner designed by Soheil Saffar, and samples inspired from David Kovalev, Ricardo Salazar, Dmitro Petrenko, Ghani Pradita, MONUiXD. Thank you all!

Let's get started #

1 - Depend on it #

Add it to your package's pubspec.yaml file #
dependencies:
  fl_chart: ^0.0.8

2 - Install it #

Install packages from the command line #
flutter packages get

3 - Learn it like a charm #

Read the docs from here

4 - Follow the roadmap #

you can follow the roadmap from here, and (let me know your suggestions)

And the last but not least 🔥 #

🍺 pull requests are welcome! #

0.0.8 #

  • added backgroundColor to axis based charts (LineChart, BarChart) to draw a solid background color behind the chart
  • added getDrawingHorizontalGridLine, getDrawingVerticalGridLine on FlGridData to determine how(color, strokeWidth) the grid lines should be drawn with the given value on FlGridLine

0.0.7 #

  • added ExtraLinesData in the LineChartData to draw extra horizontal and vertical lines on LineChart
  • added BelowSpotsLine in the BlowBarData to draw lines from spot to the bottom of chart on LineChart

0.0.6 #

  • fixed charts repainting bug, #16

0.0.5 #

  • added clipToBorder to the LineChartData to clip the drawing to the border, #3

0.0.4 #

  • fixed bug of adding bar with y = 0 on bar chart #13

0.0.3 #

  • renamed FlChartWidget to FlChart (our main widget) and now you have to import package:fl_chart/fl_chart.dart instead of package:fl_chart/fl_chart_widget.dart
  • renamed FlChart* to BaseChart* (parent class of our charts like PieChart)
  • renamed FlAxisChart* to AxisChart*

0.0.2 #

  • fixed minX, maxX functionality on LineChart
  • restricted to access private classes of the library

0.0.1 - Released on (2019 June 4) #

example/README.md

example #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fl_chart: ^0.0.8

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fl_chart/fl_chart.dart';
  
Version Uploaded Documentation Archive
0.0.8 Jun 14, 2019 Go to the documentation of fl_chart 0.0.8 Download fl_chart 0.0.8 archive
0.0.7 Jun 12, 2019 Go to the documentation of fl_chart 0.0.7 Download fl_chart 0.0.7 archive
0.0.6 Jun 9, 2019 Go to the documentation of fl_chart 0.0.6 Download fl_chart 0.0.6 archive
0.0.5 Jun 8, 2019 Go to the documentation of fl_chart 0.0.5 Download fl_chart 0.0.5 archive
0.0.4 Jun 8, 2019 Go to the documentation of fl_chart 0.0.4 Download fl_chart 0.0.4 archive
0.0.3 Jun 5, 2019 Go to the documentation of fl_chart 0.0.3 Download fl_chart 0.0.3 archive
0.0.2 Jun 4, 2019 Go to the documentation of fl_chart 0.0.2 Download fl_chart 0.0.2 archive
0.0.1 Jun 3, 2019 Go to the documentation of fl_chart 0.0.1 Download fl_chart 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
79
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
85
Overall:
Weighted score of the above. [more]
86
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/chart/base/base_chart/base_chart_data.dart. (-0.50 points)

Analysis of lib/src/chart/base/base_chart/base_chart_data.dart reported 1 hint:

line 50 col 11: Avoid using braces in interpolation when not needed.

Format lib/fl_chart.dart.

Run flutter format to format lib/fl_chart.dart.

Format lib/src/chart/bar_chart/bar_chart_data.dart.

Run flutter format to format lib/src/chart/bar_chart/bar_chart_data.dart.

Fix additional 10 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/chart/bar_chart/bar_chart_painter.dart (Run flutter format to format lib/src/chart/bar_chart/bar_chart_painter.dart.)
  • lib/src/chart/base/axis_chart/axis_chart.dart (Run flutter format to format lib/src/chart/base/axis_chart/axis_chart.dart.)
  • lib/src/chart/base/axis_chart/axis_chart_data.dart (Run flutter format to format lib/src/chart/base/axis_chart/axis_chart_data.dart.)
  • lib/src/chart/base/axis_chart/axis_chart_painter.dart (Run flutter format to format lib/src/chart/base/axis_chart/axis_chart_painter.dart.)
  • lib/src/chart/base/base_chart/base_chart_painter.dart (Run flutter format to format lib/src/chart/base/base_chart/base_chart_painter.dart.)
  • lib/src/chart/line_chart/line_chart_data.dart (Run flutter format to format lib/src/chart/line_chart/line_chart_data.dart.)
  • lib/src/chart/line_chart/line_chart_painter.dart (Run flutter format to format lib/src/chart/line_chart/line_chart_painter.dart.)
  • lib/src/chart/pie_chart/pie_chart_data.dart (Run flutter format to format lib/src/chart/pie_chart/pie_chart_data.dart.)
  • lib/src/chart/pie_chart/pie_chart_painter.dart (Run flutter format to format lib/src/chart/pie_chart/pie_chart_painter.dart.)
  • lib/src/utils/utils.dart (Run flutter format to format lib/src/utils/utils.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test