at_app_flutter 2.0.0
at_app_flutter: ^2.0.0 copied to clipboard

A library that help developers build flutter applications on the @platform.

0
likes
100/ 130
pub points
50%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 8 API elements (75.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:at_app_flutter/at_app_flutter.dart that imports:
  • package:at_app_flutter/src/models/index.dart that imports:
  • package:at_app_flutter/src/models/at_env.dart that imports:
  • package:at_onboarding_flutter/at_onboarding_flutter.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
at_client_mobile^3.0.33.0.33.0.3
at_onboarding_flutter^3.0.13.0.43.0.4
at_utils^3.0.03.0.03.0.0
dotenv^3.0.03.0.03.0.0
flutterflutter0.0.00.0.0
path_provider^2.0.52.0.52.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.63.1.6
args-2.3.02.3.0
asn1lib-1.0.21.0.2
async-2.8.22.8.2
at_backupkey_flutter-3.0.03.0.0
at_base2e15-1.0.01.0.0
at_client-3.0.43.0.4
at_commons-3.0.03.0.0
at_lookup-3.0.33.0.3
at_persistence_secondary_server-3.0.43.0.4
at_persistence_spec-2.0.12.0.1
at_server_status-1.0.31.0.3
at_utf7-1.0.01.0.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
cron-0.3.20.4.0
crypto-3.0.13.0.1
crypton-2.0.32.0.3
encrypt-5.0.15.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
file_picker-4.1.64.1.6
flutter_keychain-2.1.02.1.0
flutter_plugin_android_lifecycle-2.0.42.0.4
flutter_qr_reader-1.0.51.0.5
flutter_web_plugins-0.0.00.0.0
hive-2.0.42.0.4
http-0.13.40.13.4
http_parser-4.0.04.0.0
internet_connection_checker-0.0.1+30.0.1+3
js-0.6.30.6.3
lints-1.0.11.0.1
logging-1.0.21.0.2
meta-1.7.01.7.0
mime-1.0.11.0.1
path-1.8.01.8.0
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
permission_handler-8.2.58.2.5
permission_handler_platform_interface-3.7.03.7.0
pin_code_fields-7.3.07.3.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
pointycastle-3.3.43.3.4
process-4.2.44.2.4
share-2.0.42.0.4
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher-6.0.126.0.12
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.42.0.4
url_launcher_windows-2.0.22.0.2
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
webview_flutter-2.1.22.1.2
webview_flutter_android-2.0.152.0.15
webview_flutter_platform_interface-1.2.01.2.0
webview_flutter_wkwebview-2.0.142.0.14
win32-2.2.102.2.10
xdg_directories-0.2.00.2.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Unable to access import.

Because:

  • package:at_app_flutter/at_app_flutter.dart that imports:
  • package:at_app_flutter/src/models/index.dart that imports:
  • package:at_app_flutter/src/models/at_env.dart that imports:
  • package:at_onboarding_flutter/at_onboarding_flutter.dart that imports:
  • package:at_backupkey_flutter/at_backupkey_flutter.dart that imports:
  • package:at_backupkey_flutter/widgets/backup_key_widget.dart that imports:
  • package:at_backupkey_flutter/services/backupkey_service.dart that imports:
  • package:at_client_mobile/at_client_mobile.dart that imports:
  • package:at_client/at_client.dart that imports:
  • package:at_client/src/manager/at_client_manager.dart that imports:
  • package:at_client/src/service/sync_service_impl.dart that imports:
  • package:at_persistence_secondary_server/at_persistence_secondary_server.dart that imports:
  • package:at_persistence_secondary_server/src/notification/at_notification_manager.dart that imports:
  • package:at_persistence_secondary_server/src/notification/at_notification.dart that imports:
  • package:hive/hive.dart that imports:
  • package:hive/src/object/hive_object.dart that imports:
  • package:hive/src/object/hive_list_impl.dart that imports:
  • package:hive/src/hive_impl.dart that imports:
  • package:hive/src/backend/storage_backend.dart that imports:
  • package:hive/src/backend/js/backend_manager.dart that imports:
  • package:hive/src/backend/js/storage_backend_js.dart that imports:
  • dart:indexed_db where dart:indexed_db is inaccessible.
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

0
likes
100
pub points
50%
popularity

Publisher

atsign.org

A library that help developers build flutter applications on the @platform.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

at_client_mobile, at_onboarding_flutter, at_utils, dotenv, flutter, path_provider

More

Packages that depend on at_app_flutter