permission_handler_platform_interface 2.0.0

  • Readme
  • Changelog
  • Installing
  • 97

permission_handler_platform_interface #

pub package style: effective dart

A common platform interface for the permission_handler plugin.

This interface allows platform-specific implementations of the permission_handler plugin, as well as the plugin itself, to ensure they are supporting the same interface.

Usage #

To implement a new platform-specific implementation of permission_handler, extend PermissionHandlerPlatform with an implementation that performs the platform-specific behavior, and when you register your plugin, set the default PermissionHandlerPlatform by calling PermissionHandlerPlatform.instance = MyPlatformPermissionHandler().

Issues #

Please file any issues, bugs or feature request as an issue on our GitHub page.

Want to contribute #

If you would like to contribute to the plugin (e.g. by improving the documentation, solving a bug or adding a cool new feature), please carefully review our contribution guide and send us your pull request.

Note on breaking changes #

Strongly prefer non-breaking changes (such as adding a method to the interface) over breaking changes for this package.

See https://flutter.dev/go/platform-interface-breaking-changes for a discussion on why a less-clean interface is preferable to a breaking change.

Author #

This Permission handler plugin for Flutter is developed by Baseflow. You can contact us at hello@baseflow.com

2.0.0 #

  • BREAKING: Created a much more intuitive API using Dart's new extension methods (#230). Big thank you to @marcelgarus for the idea and doing all the grunt work.

1.0.0 #

  • Initial open-source release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  permission_handler_platform_interface: ^2.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:permission_handler_platform_interface/permission_handler_platform_interface.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
98
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
97
Learn more about scoring.

We analyzed this package on May 24, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.1
  • pana: 0.13.8-dev
  • Flutter: 1.17.0

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and permission_handler_platform_interface.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
flutter 0.0.0
meta ^1.0.5 1.1.8
plugin_platform_interface ^1.0.1 1.0.2
Transitive dependencies
collection 1.14.12
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
effective_dart ^1.2.1
flutter_test
mockito ^4.1.1