version 1.2.0

Dart native js
Flutter Android iOS web

Provides a simple class for parsing and comparing semantic versions as defined by http://semver.org/

version #

version 1.0.3 Dart CI Coverage Status

A dart library providing a Version object for comparing and incrementing version numbers in compliance with the Semantic Versioning spec at http://semver.org/

This is in contrast to pub_semver, which is close to the spec but diverts in a few specific ways.

Installation #

In your pubspec.yaml:

dependencies:
  version: ^1.0.0

Usage #

A simple usage example:

import 'package:version/version.dart';

void main() {
  Version currentVersion = new Version(1, 0, 3);
  Version latestVersion = Version.parse("2.1.0");

  if (latestVersion > currentVersion) {
    print("Update is available");
  }

  Version betaVersion = new Version(2, 1, 0, preRelease: ["beta"]);
  // Note: this test will return false, as pre-release versions are considered
  // lesser then a non-pre-release version that otherwise has the same numbers.
  if (betaVersion > latestVersion) {
    print("More recent beta available");
  }
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

17
likes
110
pub points
95%
popularity

Publisher

dart.ninja

Provides a simple class for parsing and comparing semantic versions as defined by http://semver.org/

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

More

Packages that depend on version