apptive_grid_form 0.12.3 icon indicating copy to clipboard operation
apptive_grid_form: ^0.12.3 copied to clipboard

A Flutter Package to display ApptiveGrid Forms inside a Flutter App.

4
likes
105/ 130
pub points
53%
popularity

We analyzed this package 13 hours ago, and awarded it 105 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
15 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be well formed Unable to parse 1 image link.

CHANGELOG.md:43:46

   ╷
43 │ <li>Model changes from apptive_grid_core see <a href="(https://pub.dev/packages/apptive_grid_core/changelog#0100)">here</a> for more details</li>
   │                                              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵
icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 299 out of 618 API elements (48.4 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:apptive_grid_form/apptive_grid_form.dart that imports:
  • package:apptive_grid_form/configurations/form_widget_configurations.dart that imports:
  • package:apptive_grid_core/apptive_grid_options.dart that imports:
  • package:apptive_grid_core/cache/apptive_grid_cache.dart that imports:
  • package:apptive_grid_core/apptive_grid_model.dart that imports:
  • package:apptive_grid_core/apptive_grid_network.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:apptive_grid_form/apptive_grid_form.dart that imports:
  • package:apptive_grid_form/configurations/form_widget_configurations.dart that imports:
  • package:apptive_grid_core/apptive_grid_options.dart that imports:
  • package:apptive_grid_core/cache/apptive_grid_cache.dart that imports:
  • package:apptive_grid_core/apptive_grid_model.dart that imports:
  • package:apptive_grid_core/apptive_grid_network.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:apptive_grid_form/apptive_grid_form.dart that imports:
  • package:apptive_grid_form/configurations/form_widget_configurations.dart that imports:
  • package:apptive_grid_core/apptive_grid_options.dart that imports:
  • package:apptive_grid_core/cache/apptive_grid_cache.dart that imports:
  • package:apptive_grid_core/apptive_grid_model.dart that imports:
  • package:apptive_grid_core/apptive_grid_network.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:apptive_grid_form/apptive_grid_form.dart that imports:
  • package:apptive_grid_form/widgets/apptive_grid_form_widgets.dart that imports:
  • package:apptive_grid_form/widgets/geolocation/geolocation_map.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:apptive_grid_form/apptive_grid_form.dart that imports:
  • package:apptive_grid_form/widgets/apptive_grid_form_widgets.dart that imports:
  • package:apptive_grid_form/widgets/geolocation/geolocation_input.dart that imports:
  • package:apptive_grid_form/managers/location_manager.dart that imports:
  • package:geolocator/geolocator.dart that imports:
  • package:geolocator_apple/geolocator_apple.dart that declares support for platforms: iOS, macOS.
Package does not support platform `iOS`.

Because:

  • package:apptive_grid_form/apptive_grid_form.dart that imports:
  • package:apptive_grid_form/widgets/apptive_grid_form_widgets.dart that imports:
  • package:apptive_grid_form/widgets/geolocation/geolocation_input.dart that imports:
  • package:apptive_grid_form/managers/location_manager.dart that imports:
  • package:geolocator/geolocator.dart that imports:
  • package:geolocator_android/geolocator_android.dart that declares support for platforms: Android.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/google_maps_webservice/core.g.dart:71:13

   ╷
71 │ _TravelMode _$_TravelModeFromJson(Map<String, dynamic> json) {
   │             ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/google_maps_webservice/core.g.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/google_maps_webservice/core.g.dart:77:22

   ╷
77 │ Map<String, dynamic> _$_TravelModeToJson(_TravelMode instance) =>
   │                      ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/google_maps_webservice/core.g.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
apptive_grid_core^0.12.00.12.20.12.2
file_picker^4.6.04.6.15.0.1
flutterflutter0.0.00.0.0
flutter_svg^1.1.11.1.31.1.3
flutter_typeahead^4.0.04.0.04.0.0
geolocator^8.2.18.2.19.0.1
google_maps_flutter^2.1.82.1.102.1.10
google_maps_flutter_platform_interface^2.1.72.2.12.2.1
http^0.13.40.13.50.13.5
image_picker^0.8.5+30.8.5+30.8.5+3
intl^0.17.00.17.00.17.0
linked_scroll_controller^0.2.00.2.00.2.0
lottie^1.3.01.4.11.4.1
permission_handler^9.2.09.2.010.0.0
permission_handler_platform_interface^3.7.03.7.03.7.0
provider^6.0.36.0.36.0.3
universal_file^1.0.01.0.01.0.0
universal_platform^1.0.0+11.0.0+11.0.0+1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.3.13.3.1
args-2.3.12.3.1
asn1lib-1.1.01.1.0
async-2.9.02.9.0
characters-1.2.01.2.1
clock-1.1.11.1.1
collection-1.16.01.16.0
convert-3.0.23.0.2
cross_file-0.3.3+10.3.3+1
crypto-3.0.23.0.2
crypto_keys-0.3.00.3.0
ffi-1.2.12.0.1
flutter_keyboard_visibility-5.3.05.3.0
flutter_keyboard_visibility_platform_interface-2.0.02.0.0
flutter_keyboard_visibility_web-2.0.02.0.0
flutter_plugin_android_lifecycle-2.0.72.0.7
flutter_secure_storage-5.1.05.1.0
flutter_secure_storage_linux-1.1.11.1.1
flutter_secure_storage_macos-1.1.11.1.1
flutter_secure_storage_platform_interface-1.0.01.0.0
flutter_secure_storage_web-1.0.21.0.2
flutter_secure_storage_windows-1.1.21.1.2
flutter_web_plugins-0.0.00.0.0
geolocator_android-3.2.14.0.2
geolocator_apple-2.2.12.2.1
geolocator_platform_interface-4.0.64.0.6
geolocator_web-2.1.62.1.6
geolocator_windows-0.1.10.1.1
http_parser-4.0.14.0.1
image-3.2.03.2.0
image_picker_android-0.8.5+20.8.5+2
image_picker_for_web-2.1.82.1.8
image_picker_ios-0.8.5+60.8.5+6
image_picker_platform_interface-2.6.12.6.1
jose-0.3.20.3.2
js-0.6.40.6.4
logging-1.0.21.0.2
matcher-0.12.120.12.12
material_color_utilities-0.1.40.2.0
meta-1.7.01.8.0
mime-1.0.21.0.2
nested-1.0.01.0.0
openid_client-0.4.60.4.6
path-1.8.21.8.2
path_drawing-1.0.11.0.1
path_parsing-1.0.11.0.1
permission_handler_android-9.0.2+110.0.0
permission_handler_apple-9.0.49.0.4
permission_handler_windows-0.1.00.1.0
petitparser-5.0.05.0.0
plugin_platform_interface-2.1.22.1.2
pointycastle-3.6.13.6.1
quiver-3.1.03.1.0
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
stack_trace-1.10.01.10.0
stream_transform-2.0.02.0.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uni_links-0.5.10.5.1
uni_links_platform_interface-1.0.01.0.0
uni_links_web-0.1.00.1.0
url_launcher-6.1.56.1.5
url_launcher_android-6.0.176.0.17
url_launcher_ios-6.0.176.0.17
url_launcher_linux-3.0.13.0.1
url_launcher_macos-3.0.13.0.1
url_launcher_platform_interface-2.1.02.1.0
url_launcher_web-2.0.132.0.13
url_launcher_windows-3.0.13.0.1
uuid-3.0.63.0.6
vector_math-2.1.22.1.2
win32-2.6.12.7.0
x509-0.2.20.2.2
xml-6.1.06.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^4.6.0` on file_picker does not support the stable version `5.0.0`, that was published 17 days ago.

When file_picker is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions file_picker to update the constraint.

The constraint `^8.2.1` on geolocator does not support the stable version `9.0.0`.

Try running dart pub upgrade --major-versions geolocator to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.15, Flutter 3.0.5, Dart 2.17.6.