x509 0.1.0+1

  • Readme
  • Changelog
  • Example
  • Installing
  • 89

x509 #

Dart library for parsing and working with X.509 certificates.

Usage #

A simple usage example:

import 'package:x509/x509.dart';
import 'dart:io';

main() {
  var cert = parsePem(new File('cert.pem').readAsStringSync());
  
  print(cert);
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.1.0 #

  • Initial version

example/main.dart

import 'package:x509/x509.dart';
import 'dart:io';

void main() {
  var certRequest = parsePem(File('test/files/csr.pem').readAsStringSync())
      .first as CertificationRequest;

  print(certRequest.certificationRequestInfo.subject);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  x509: ^0.1.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:x509/x509.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
78
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
89
Learn more about scoring.

We analyzed this package on Apr 6, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
asn1lib ^0.6.0 0.6.4
crypto_keys ^0.1.0 0.1.0+2
quiver ^2.0.0 2.1.3
Transitive dependencies
built_collection 4.3.2
built_value 7.0.9
collection 1.14.12
fixnum 0.10.11
matcher 0.12.6
meta 1.1.8
path 1.6.4
pointycastle 1.0.2
stack_trace 1.9.3
Dev dependencies
pedantic ^1.9.0
test ^1.0.0