nginx_le 8.4.0 icon indicating copy to clipboard operation
nginx_le: ^8.4.0 copied to clipboard

Nginx-LE provides a docker container and tools to create an Nginx web server that automatically acquires and renews HTTPS certificates.

3
likes
140/ 140
pub points
0%
popularity

We analyzed this package 43 hours ago, and awarded it 140 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 14 out of 26 API elements (53.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package does not support platform Android.

Because:

  • package:nginx_le/nginx_le.dart that imports:
  • package:nginx_le/src/commands/external/start_command.dart that imports:
  • package:nginx_le_shared/nginx_le_shared.dart that imports:
  • package:nginx_le_shared/src/util/environment.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.

Package does not support platform iOS.

Because:

  • package:nginx_le/nginx_le.dart that imports:
  • package:nginx_le/src/commands/external/start_command.dart that imports:
  • package:nginx_le_shared/nginx_le_shared.dart that imports:
  • package:nginx_le_shared/src/util/environment.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.

Package does not support platform Web.

Because:

  • package:nginx_le/nginx_le.dart that imports:
  • package:nginx_le/src/commands/external/start_command.dart that imports:
  • package:nginx_le_shared/nginx_le_shared.dart that imports:
  • package:nginx_le_shared/src/util/environment.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform Linux.

Because:

  • package:nginx_le/nginx_le.dart that imports:
  • package:nginx_le/src/commands/external/start_command.dart that imports:
  • package:nginx_le_shared/nginx_le_shared.dart that imports:
  • package:nginx_le_shared/src/util/environment.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console2/dart_console2.dart that imports:
  • package:dart_console2/src/console.dart that imports:
  • package:dart_console2/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.

Package does not support platform macOS.

Because:

  • package:nginx_le/nginx_le.dart that imports:
  • package:nginx_le/src/commands/external/start_command.dart that imports:
  • package:nginx_le_shared/nginx_le_shared.dart that imports:
  • package:nginx_le_shared/src/util/environment.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console2/dart_console2.dart that imports:
  • package:dart_console2/src/console.dart that imports:
  • package:dart_console2/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.0.02.3.12.3.1
async^2.4.22.10.02.10.0
cron^0.5.00.5.10.5.1
dcli^1.36.01.36.01.36.0
docker2^2.2.02.2.82.2.8
encrypt^5.0.05.0.15.0.1
http^0.13.00.13.50.13.5
intl^0.17.00.17.00.17.0
isolates^3.0.03.0.3+83.0.3+8
meta^1.0.01.8.01.8.0
nginx_le_shared^8.4.08.4.08.4.0
path^1.6.41.8.21.8.2
pub_release^8.2.08.2.08.2.0
pub_semver^2.0.02.1.32.1.3
public_suffix^3.0.03.0.03.0.0
settings_yaml^4.0.04.0.15.0.0
uuid^3.0.03.0.73.0.7
validators2^3.0.03.0.03.0.0
xml^6.1.06.2.26.2.2
yaml^3.0.03.1.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.3.53.3.5
asn1lib-1.4.01.4.0
basic_utils-3.9.45.4.2
characters-1.2.11.2.1
chunked_stream-1.4.11.4.1
circular_buffer-0.11.00.11.0
clock-1.1.11.1.1
collection-1.17.01.17.0
convert-3.1.13.1.1
crypto-3.0.23.0.2
csv-5.0.15.0.1
dart_console2-2.0.12.0.1
dcli_core-1.36.01.36.0
equatable-2.0.52.0.5
ffi-2.0.12.0.1
file-6.1.46.1.4
file_utils-1.0.11.0.1
functional_data-1.0.01.0.0
github-9.7.09.7.0
glob-2.1.12.1.1
globbing-1.0.01.0.0
http_parser-4.0.24.0.2
ini-2.1.02.1.0
instant-0.4.10.4.1
js-0.6.50.6.5
json2yaml-3.0.03.0.0
json_annotation-4.7.04.7.0
logging-1.1.01.1.0
mailer-5.2.05.2.0
matcher-0.12.130.12.13
mime-1.0.31.0.3
pedantic-1.11.11.11.1
petitparser-5.1.05.1.0
pointycastle-3.6.23.6.2
posix-4.1.04.1.0
pubspec2-2.4.12.4.1
pubspec_lock-3.0.13.0.1
punycode-1.0.01.0.0
quiver-3.1.03.1.0
random_string-2.3.12.3.1
scope-3.0.03.0.0
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
stacktrace_impl-2.3.02.3.0
string_scanner-1.2.01.2.0
sum_types-0.3.40.3.4
system_info2-2.0.42.0.4
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uri-1.0.01.0.0
vin_decoder-0.2.1-nullsafety0.2.1-nullsafety
win32-3.1.23.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^4.0.0 on settings_yaml does not support the stable version 5.0.0, that was published 15 days ago.

When settings_yaml is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions settings_yaml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Dart 2.18.4.

3
likes
140
pub points
0%
popularity

Publisher

verified publisher icononepub.dev

Nginx-LE provides a docker container and tools to create an Nginx web server that automatically acquires and renews HTTPS certificates.

Repository (GitHub)

Documentation

Documentation
API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

args, async, cron, dcli, docker2, encrypt, http, intl, isolates, meta, nginx_le_shared, path, pub_release, pub_semver, public_suffix, settings_yaml, uuid, validators2, xml, yaml

More

Packages that depend on nginx_le