A package that provides a shelf handler for serving a
It's intended to be usable as the first handler in a
any requests that include
/packages/ are served package assets, and all other
requests cascade to additional handlers.
- Set max SDK version to
<3.0.0, and adjust other dependencies.
- Require Dart SDK 1.22.0
- Fix Strong mode errors with
- Allow dependencies on
- Initial version
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: shelf_packages_handler: ^1.0.4
2. Install it
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Sep 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.5.0
- pana: 0.12.21
Detected platforms: Flutter, other
lib/src/async_handler.dart. (-0.50 points)
lib/src/async_handler.dart reported 1 hint:
line 21 col 7: DO use curly braces for all flow control structures.
Package is getting outdated. (-15.62 points)
The package was last published 60 weeks ago.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
shelf_packages_handler.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
The package description is too short. (-8 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
|Dart SDK||>=1.22.0 <3.0.0|