webkit_inspection_protocol 0.5.0

webkit_inspection_protocol.dart #

Build Status pub package

What is it? #

The webkit_inspection_protocol package is a client for the Chrome DevTools Protocol (previously called the Webkit Inspection Protocol). It's used to talk to Chrome DevTools based debuggers.

The protocol #

Read more about the protocol here.

Disclaimer #

This is not an official Google product.

webkit_inspection_protocol.dart #

0.5.0 #

  • removed the bin/multiplex.dart binary to the example/ directory
  • remove dependencies on package:args, package:shelf, andpackage:shelf_web_socket`

0.4.2 #

  • Cast HttpClientResponse to Stream<List<int>> in response to SDK breaking change.

0.4.1 #

  • Fix page.reload method.
  • Disable implicit casts when developing this package.

0.4.0 #

  • Change the RemoteObject.value return type to Object.

0.3.6 #

  • Expose the target domain and additional runtime domain calls

0.3.5 #

  • Widen the Dart SDK constraint

0.3.4 #

  • Several fixes for strong mode at runtime issues
  • Rename uses of deprecated dart:io constants

0.3.3 #

  • Upgrade the Dart SDK minimum to 2.0.0-dev
  • Rename uses of deprecated dart:convert constants

0.3.2 #

  • Analysis fixes for strong mode
  • Upgrade to the latest package dependencies

0.3.1 #

  • Expose ConsoleAPIEvent.timestamp
  • Expose LogEntry.timestamp

0.3.0 #

  • Expose the runtime domain.
  • Expose the log domain.
  • Deprecated the console domain.
  • Fix a bug in Page.reload().
  • Remove the use of parts.

0.2.2 #

  • Make the package strong mode clean.

0.2.1+1 #

0.0.1 #

  • Initial version (library moved out of the grinder package).

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  webkit_inspection_protocol: ^0.5.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:webkit_inspection_protocol/webkit_inspection_protocol.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
92
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
96
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, other

Primary library: package:webkit_inspection_protocol/webkit_inspection_protocol.dart with components: io.

Health suggestions

Fix lib/webkit_inspection_protocol.dart. (-1 points)

Analysis of lib/webkit_inspection_protocol.dart reported 2 hints:

line 131 col 3: 'WipConsole' is deprecated and shouldn't be used.

line 171 col 20: 'WipConsole' is deprecated and shouldn't be used.

Maintenance suggestions

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and webkit_inspection_protocol.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
logging ^0.11.0 0.11.3+2
Dev dependencies
args >=0.13.0 <2.0.0
shelf ^0.7.0
shelf_static ^0.2.0
shelf_web_socket ^0.2.0
test ^1.0.0