firebase_dart_flutter 1.0.0
firebase_dart_flutter: ^1.0.0 copied to clipboard

A port of the Firebase database, auth and storage client to pure Dart code for use on flutter

0
likes
80/ 130
pub points
64%
popularity

We analyzed this package 4 days ago, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 4 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `iOS`.

Because:

  • package:firebase_dart_flutter/firebase_dart_flutter.dart that declares support for platforms: Android.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_dart^1.0.01.0.31.0.3
flutterflutter0.0.00.0.0
flutter_facebook_auth^3.3.03.5.6+33.5.6+3
google_sign_in^5.0.05.2.15.2.1
hive^2.0.02.0.42.0.4
package_info^2.0.02.0.22.0.2
path_provider^2.0.02.0.72.0.7
platform_info^3.0.03.1.03.1.0
sign_in_with_apple^3.0.03.3.03.3.0
url_launcher^6.0.06.0.176.0.17
Transitive dependencies
PackageConstraintCompatibleLatest
_discoveryapis_commons-1.0.21.0.2
args-2.3.02.3.0
asn1lib-1.0.31.0.3
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
crypto_keys-0.3.00.3.0
expressions-0.2.30.2.3
fake_async-1.2.01.2.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_facebook_auth_platform_interface-2.7.02.7.0
flutter_facebook_auth_web-2.6.0+22.6.0+2
flutter_web_plugins-0.0.00.0.0
google_sign_in_platform_interface-2.1.02.1.0
google_sign_in_web-0.10.0+30.10.0+3
googleapis-6.0.07.0.0
googleapis_auth-1.3.01.3.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
jose-0.3.20.3.2
js-0.6.30.6.3
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
openid_client-0.4.30.4.3
path-1.8.01.8.0
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.32.0.3
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
pointycastle-3.4.03.4.0
process-4.2.44.2.4
quiver-3.0.1+13.0.1+1
rxdart-0.27.30.27.3
sign_in_with_apple_platform_interface-1.0.01.0.0
sign_in_with_apple_web-1.0.11.0.1
sky_engine-0.0.990.0.99
sortedmap-0.5.10.5.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_android-6.0.136.0.13
url_launcher_ios-6.0.136.0.13
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.52.0.5
url_launcher_windows-2.0.22.0.2
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
web_socket_channel-2.1.02.1.0
win32-2.3.12.3.1
x509-0.2.20.2.2
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Unable to access import.

Because:

  • package:firebase_dart_flutter/firebase_dart_flutter.dart that imports:
  • package:hive/hive.dart that imports:
  • package:hive/src/object/hive_object.dart that imports:
  • package:hive/src/object/hive_list_impl.dart that imports:
  • package:hive/src/hive_impl.dart that imports:
  • package:hive/src/backend/storage_backend.dart that imports:
  • package:hive/src/backend/js/backend_manager.dart that imports:
  • package:hive/src/backend/js/storage_backend_js.dart that imports:
  • dart:indexed_db where dart:indexed_db is inaccessible.
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.