package_info 0.4.0+10

  • Readme
  • Changelog
  • Example
  • Installing
  • 100

PackageInfo #

This Flutter plugin provides an API for querying information about an application package.

Usage #

You can use the PackageInfo to query information about the application package. This works both on iOS and Android.

import 'package:package_info/package_info.dart';

PackageInfo packageInfo = await PackageInfo.fromPlatform();

String appName = packageInfo.appName;
String packageName = packageInfo.packageName;
String version = packageInfo.version;
String buildNumber = packageInfo.buildNumber;

Or in async mode:

PackageInfo.fromPlatform().then((PackageInfo packageInfo) {
  String appName = packageInfo.appName;
  String packageName = packageInfo.packageName;
  String version = packageInfo.version;
  String buildNumber = packageInfo.buildNumber;
});

Known Issue #

As noted on issue 20761, package_info on iOS requires the Xcode build folder to be rebuilt after changes to the version string in pubspec.yaml. Clean the Xcode build folder with: XCode Menu -> Product -> (Holding Option Key) Clean build folder.

Issues and feedback #

Please file issues to send feedback or report a bug. Thank you!

0.4.0+10 #

  • Include lifecycle dependency as a compileOnly one on Android to resolve potential version conflicts with other transitive libraries.

0.4.0+9 #

  • Android: Use android.arch.lifecycle instead of androidx.lifecycle:lifecycle in build.gradle to support apps that has not been migrated to AndroidX.

0.4.0+8 #

  • Support the v2 Android embedder.
  • Update to AndroidX.
  • Add a unit test.
  • Migrate to using the new e2e test binding.

0.4.0+7 #

  • Update and migrate iOS example project.
  • Define clang module for iOS.

0.4.0+6 #

  • Fix Android compiler warnings.

0.4.0+5 #

  • Add iOS-specific warning to README.md.

0.4.0+4 #

  • Add missing template type parameter to invokeMethod calls.
  • Bump minimum Flutter version to 1.5.0.
  • Replace invokeMethod with invokeMapMethod wherever necessary.

0.4.0+3 #

  • Add integration test.

0.4.0+2 #

  • Android: Using new method for BuildNumber in new android versions

0.4.0+1 #

  • Log a more detailed warning at build time about the previous AndroidX migration.

0.4.0 #

  • Breaking change. Migrate from the deprecated original Android Support Library to AndroidX. This shouldn't result in any functional changes, but it requires any Android apps using this plugin to also migrate if they're using the original support library.

0.3.2+1 #

  • Fixed a crash on IOS when some of the package infos are not available.

0.3.2 #

  • Updated Gradle tooling to match Android Studio 3.1.2.

0.3.1 #

  • Added appName field to PackageInfo for getting the display name of the app.

0.3.0 #

  • Breaking change. Set SDK constraints to match the Flutter beta release.

0.2.1 #

  • Fixed Dart 2 type error.

0.2.0 #

  • Breaking change. Introduced class PackageInfo in place of individual functions.
  • PackageInfo provides all package information with a single async call.

0.1.1 #

  • Added package name to available information.
  • Simplified and upgraded Android project template to Android SDK 27.
  • Updated package description.

0.1.0 #

  • Breaking change. Upgraded to Gradle 4.1 and Android Studio Gradle plugin 3.0.1. Older Flutter projects need to upgrade their Gradle setup as well in order to use this version of the plugin. Instructions can be found here.

0.0.2 #

  • Add FLT prefix to iOS types

0.0.1 #

  • Initial release

example/README.md

package_info_example #

Demonstrates how to use the package_info plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  package_info: ^0.4.0+10

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:package_info/package_info.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
100
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
100
Learn more about scoring.

We analyzed this package on Nov 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
e2e ^0.2.1
flutter_driver
flutter_test
test any