enough_mail_flutter 2.1.0 copy "enough_mail_flutter: ^2.1.0" to clipboard
enough_mail_flutter: ^2.1.0 copied to clipboard

Widgets for email apps that use the `enough_mail` library. Licensed commercially friendly under MPL 2.0.

4
likes
130/ 140
pub points
63%
popularity

We analyzed this package 22 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MPL-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

5033 out of 5698 API elements (88.3 %) have documentation comments.

Some symbols that are missing documentation: enough_mail_flutter.ASN1DERDecoder, enough_mail_flutter.ASN1DERDecoder.ASN1DERDecoder, enough_mail_flutter.ASN1DERDecoder.decode, enough_mail_flutter.ASN1DERDecoder.getContentLength, enough_mail_flutter.ASN1DERDecoder.loadSubContent.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:enough_mail_flutter/enough_mail_flutter.dart that imports:
  • package:enough_mail_flutter/src/mime_message_viewer.dart that imports:
  • package:enough_mail_flutter/src/mime_media_provider.dart that imports:
  • package:enough_media/enough_media.dart that imports:
  • package:chewie_audio/chewie_audio.dart that imports:
  • package:chewie_audio/src/material/material_controls.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:enough_mail_flutter/enough_mail_flutter.dart that imports:
  • package:enough_mail_flutter/src/mime_message_viewer.dart that imports:
  • package:enough_mail_flutter/src/mime_media_provider.dart that imports:
  • package:enough_media/enough_media.dart that imports:
  • package:chewie_audio/chewie_audio.dart that imports:
  • package:chewie_audio/src/material/material_controls.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Web`.

Because:

  • package:enough_mail_flutter/enough_mail_flutter.dart that imports:
  • package:enough_mail_flutter/src/mime_message_viewer.dart that imports:
  • package:enough_mail_flutter/src/mime_media_provider.dart that imports:
  • package:enough_media/enough_media.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_desktop_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock_plus/wakelock_plus.dart that imports:
  • package:wakelock_plus/src/wakelock_plus_linux_plugin.dart that imports:
  • package:dbus/dbus.dart that declares support for platforms: Windows, Linux.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:enough_mail_flutter/enough_mail_flutter.dart that imports:
  • package:enough_mail_flutter/src/mime_message_viewer.dart that imports:
  • package:enough_mail_flutter/src/mime_media_provider.dart that imports:
  • package:enough_media/enough_media.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_desktop_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock_plus/wakelock_plus.dart that imports:
  • package:wakelock_plus/src/wakelock_plus_windows_plugin.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:enough_mail_flutter/enough_mail_flutter.dart that imports:
  • package:enough_mail_flutter/src/mime_message_viewer.dart that imports:
  • package:enough_mail_flutter/src/mime_media_provider.dart that imports:
  • package:enough_media/enough_media.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_desktop_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock_plus/wakelock_plus.dart that imports:
  • package:wakelock_plus/src/wakelock_plus_windows_plugin.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:enough_mail_flutter/enough_mail_flutter.dart that imports:
  • package:enough_mail_flutter/src/mime_message_viewer.dart that imports:
  • package:enough_mail_flutter/src/mime_media_provider.dart that imports:
  • package:enough_media/enough_media.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_desktop_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock_plus/wakelock_plus.dart that imports:
  • package:wakelock_plus/src/wakelock_plus_windows_plugin.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'WillPopScope' is deprecated and shouldn't be used. Use PopScope instead. This feature was deprecated after v3.12.0-1.0.pre.

lib/src/mime_message_viewer.dart:210:14

    ╷
210 │       return WillPopScope(
    │              ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/mime_message_viewer.dart

INFO: 'WillPopScope.new' is deprecated and shouldn't be used. Use PopScope instead. This feature was deprecated after v3.12.0-1.0.pre.

lib/src/mime_message_viewer.dart:210:14

    ╷
210 │       return WillPopScope(
    │              ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/mime_message_viewer.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
enough_mail ^2.1.2 2.1.6 2.1.6
enough_mail_html ^2.0.1 2.0.1 2.0.1
enough_media ^2.2.1 2.2.2 2.2.2
flutter flutter 0.0.0 0.0.0
flutter_inappwebview ^6.0.0-beta.25 6.0.0 6.0.0
url_launcher ^6.1.14 6.2.6 6.2.6
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.4.10 3.4.10
args - 2.5.0 2.5.0
asn1lib - 1.5.2 1.5.2
async - 2.11.0 2.11.0
basic_utils - 5.7.0 5.7.0
characters - 1.3.0 1.3.0
chewie - 1.8.1 1.8.1
chewie_audio - 1.5.0 1.5.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
csslib - 1.0.0 1.0.0
cupertino_icons - 1.0.8 1.0.8
dbus - 0.7.10 0.7.10
device_info_plus - 9.1.2 10.1.0
device_info_plus_platform_interface - 7.0.0 7.0.0
encrypt - 5.0.3 5.0.3
enough_convert - 1.6.0 1.6.0
event_bus - 2.0.0 2.0.0
extension - 0.6.0 0.6.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_inappwebview_android - 1.0.13 1.0.13
flutter_inappwebview_internal_annotations - 1.1.1 1.1.1
flutter_inappwebview_ios - 1.0.13 1.0.13
flutter_inappwebview_macos - 1.0.11 1.0.11
flutter_inappwebview_platform_interface - 1.0.10 1.0.10
flutter_inappwebview_web - 1.0.8 1.0.8
flutter_web_plugins - 0.0.0 0.0.0
html - 0.15.4 0.15.4
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
image - 4.1.7 4.1.7
intl - 0.19.0 0.19.0
js - 0.6.7 0.7.1
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
nested - 1.0.0 1.0.0
package_info_plus - 7.0.0 8.0.0
package_info_plus_platform_interface - 3.0.0 3.0.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
pdfx - 2.6.0 2.6.0
petitparser - 6.0.2 6.0.2
photo_view - 0.14.0 0.15.0
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pointycastle - 3.9.0 3.9.0
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
universal_platform - 1.0.0+1 1.0.0+1
url_launcher_android - 6.3.1 6.3.1
url_launcher_ios - 6.2.5 6.2.5
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.1.0 3.1.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
video_player - 2.8.6 2.8.6
video_player_android - 2.4.14 2.4.14
video_player_avfoundation - 2.5.7 2.5.7
video_player_platform_interface - 6.2.2 6.2.2
video_player_web - 2.3.0 2.3.0
wakelock_plus - 1.2.4 1.2.4
wakelock_plus_platform_interface - 1.2.1 1.2.1
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
win32_registry - 1.1.3 1.1.3
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

4
likes
130
pub points
63%
popularity

Publisher

verified publisherenough.de

Widgets for email apps that use the `enough_mail` library. Licensed commercially friendly under MPL 2.0.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MPL-2.0 (LICENSE)

Dependencies

enough_mail, enough_mail_html, enough_media, flutter, flutter_inappwebview, url_launcher

More

Packages that depend on enough_mail_flutter