carp_mobile_sensing 0.20.3
carp_mobile_sensing: ^0.20.3 copied to clipboard

Mobile Sensing Framework for Flutter. A software framework for collecting sensor data from the phone and attached wearable devices via probes. Can be extended.

11
likes
80 / 110
pub points
69 %
popularity

We analyzed this package on Apr 14, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 902 out of 1276 API elements (70.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:carp_mobile_sensing/carp_mobile_sensing.dart that imports:
  • package:carp_mobile_sensing/sampling_packages/sensors/sensors.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

INFO: Use `;` instead of `{}` for empty constructor bodies.

lib/domain/device_info.dart:19:18

   ╷
19 │   DeviceInfo._() {}
   │                  ^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/domain/device_info.dart

INFO: Equality operator `==` invocation with references of unrelated types.

lib/runtime/probe_registry.dart:38:29

   ╷
38 │       .where((dataPoint) => dataPoint.carpHeader.dataFormat == type);
   │                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/runtime/probe_registry.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^2.0.42.0.133.1.2
async^2.4.02.5.02.5.0
battery>=0.3.0 <2.0.01.0.112.0.1
carp_core^0.20.00.20.3+10.20.3+1
cron^0.2.30.2.40.3.0
device_apps^1.0.81.3.02.0.2
device_info>=0.4.2 <2.0.01.0.02.0.0
flutterflutter0.0.00.0.0
json_annotation^3.0.03.1.14.0.1
light^1.0.11.0.11.0.1
meta^1.1.81.3.01.3.0
package_info>=0.4.0 <2.0.00.4.3+42.0.0
path_provider^1.2.01.6.282.0.1
pedometer^2.0.22.1.02.1.0
permission_handler^5.0.05.1.0+26.1.1
permission_handler_platform_interface^2.0.12.0.23.1.3
screen_state^1.0.01.0.11.0.1
sensors>=0.4.2 <2.0.00.4.2+62.0.0
shared_preferences>=0.5.7 <2.0.00.5.12+42.0.5
stats^1.0.01.0.12.0.0
system_info^0.1.00.1.31.0.0
uuid^2.0.02.2.23.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.0.0
battery_platform_interface-1.0.02.0.1
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
device_info_platform_interface-1.0.12.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
file_utils-0.1.41.0.0
flutter_web_plugins-0.0.00.0.0
globbing-0.3.11.0.0
js-0.6.30.6.3
path-1.8.01.8.0
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 15 issues. Showing the first 2:

The constraint `^2.0.4` on archive does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions archive to update the constraint.

The constraint `>=0.3.0 <2.0.0` on battery does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions battery to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

11
likes
80
pub points
69%
popularity

Publisher

cachet.dk

Mobile Sensing Framework for Flutter. A software framework for collecting sensor data from the phone and attached wearable devices via probes. Can be extended.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

archive, async, battery, carp_core, cron, device_apps, device_info, flutter, json_annotation, light, meta, package_info, path_provider, pedometer, permission_handler, permission_handler_platform_interface, screen_state, sensors, shared_preferences, stats, system_info, uuid

More

Packages that depend on carp_mobile_sensing