screen_state 0.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 86

screen_state #

pub package

A Flutter plugin for tracking the screen state.

Install #

Add screen_state as a dependency in pubspec.yaml. For help on adding as a dependency, view the documentation.

Usage #

All incoming data points are streamed with a StreamSubscription which is set up by calling the listen() method on the screenStateStream stream object.

Given a method _onData(ScreenStateEvent event) the subscription can be set up as follows:

Screen _screen;
StreamSubscription<ScreenStateEvent> _subscription;
void onData(ScreenStateEvent event) {

void startListening() {
    _screen = new Screen();
    try {
      _subscription = _screen.screenStateStream.listen(onData);
    } on ScreenStateException catch (exception) {

The stream can also be cancelled again by calling the cancel() method:

  void stopListening() {

0.0.1 #

  • TODO: Describe initial release.


screen_state_example #

Demonstrates how to use the screen_state plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  screen_state: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:screen_state/screen_state.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Nov 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8