videosdk 0.0.13 icon indicating copy to clipboard operation
videosdk: ^0.0.13 copied to clipboard

Video SDK Flutter to simply integrate Audio & Video Calling API or Live Video Streaming API to your app with just a few lines of code.

23
likes
100/ 130
pub points
83%
popularity

We analyzed this package 22 hours ago, and awarded it 100 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 133 API elements (0.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:videosdk/rtc.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:videosdk/rtc.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:videosdk/rtc.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:videosdk/rtc.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:videosdk/rtc.dart that imports:
  • package:videosdk/src/stream.dart that imports:
  • package:videosdk/src/features/signaling/room_client_repository.dart that imports:
  • package:flutter_foreground_task/flutter_foreground_task.dart that imports:
  • package:shared_preferences_ios/shared_preferences_ios.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:videosdk/rtc.dart that imports:
  • package:videosdk/src/stream.dart that imports:
  • package:videosdk/src/features/signaling/room_client_repository.dart that imports:
  • package:flutter_foreground_task/flutter_foreground_task.dart that imports:
  • package:shared_preferences_android/shared_preferences_android.dart that declares support for platforms: Android.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 35 issues. Showing the first 2:

INFO: The value of the local variable 'scalabilityMode' isn't used.

lib/src/features/signaling/room_client_repository.dart:393:21

    ╷
393 │     ScalabilityMode scalabilityMode = ScalabilityMode.parse(
    │                     ^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/features/signaling/room_client_repository.dart

INFO: The value of the field '_app_name' isn't used.

lib/src/protoo_client/src/logger.dart:2:10

  ╷
2 │   String _app_name;
  │          ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/protoo_client/src/logger.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^7.1.07.2.18.0.3
collection^1.15.01.16.01.16.0
encrypt^5.0.15.0.15.0.1
equatable^2.0.32.0.32.0.3
events2^1.0.01.0.01.0.0
flutterflutter0.0.00.0.0
flutter_bloc^7.0.17.3.38.0.1
flutter_foreground_task^3.4.13.7.33.7.3
flutter_webrtc^0.8.50.8.90.8.9
h264_profile_level_id^0.2.00.2.00.2.0
http^0.13.40.13.40.13.4
random_string^2.3.12.3.12.3.1
sdp_transform^0.3.20.3.20.3.2
synchronized^3.0.03.0.0+23.0.0+2
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.12.3.1
asn1lib-1.1.01.1.0
async-2.9.02.9.0
characters-1.2.01.2.1
clock-1.1.11.1.1
convert-3.0.23.0.2
crypto-3.0.23.0.2
dart_webrtc-1.0.61.0.6
ffi-2.0.12.0.1
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.14.0.1
js-0.6.40.6.4
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
nested-1.0.01.0.0
path-1.8.21.8.2
path_provider-2.0.112.0.11
path_provider_android-2.0.152.0.15
path_provider_ios-2.0.102.0.10
path_provider_linux-2.1.72.1.7
path_provider_macos-2.0.62.0.6
path_provider_platform_interface-2.0.42.0.4
path_provider_windows-2.1.02.1.0
platform-3.1.03.1.0
plugin_platform_interface-2.1.22.1.2
pointycastle-3.6.03.6.0
process-4.2.44.2.4
provider-6.0.36.0.3
shared_preferences-2.0.152.0.15
shared_preferences_android-2.0.122.0.12
shared_preferences_ios-2.1.12.1.1
shared_preferences_linux-2.1.12.1.1
shared_preferences_macos-2.0.42.0.4
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.42.0.4
shared_preferences_windows-2.1.12.1.1
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2
webrtc_interface-1.0.51.0.5
win32-2.7.02.7.0
xdg_directories-0.2.0+10.2.0+1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.1.0` on bloc does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions bloc to update the constraint.

The constraint `^7.0.1` on flutter_bloc does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions flutter_bloc to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.

23
likes
100
pub points
83%
popularity

Publisher

verified publisher iconvideosdk.live

Video SDK Flutter to simply integrate Audio & Video Calling API or Live Video Streaming API to your app with just a few lines of code.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

bloc, collection, encrypt, equatable, events2, flutter, flutter_bloc, flutter_foreground_task, flutter_webrtc, h264_profile_level_id, http, random_string, sdp_transform, synchronized

More

Packages that depend on videosdk