socket_io_common 0.9.0+5

socket_io_common #

Socket.io common parser library for Dart 2

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  socket_io_common: ^0.9.0+5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:socket_io_common/socket_io_common.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
67
Health:
Code health derived from static analysis. [more]
74
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Nov 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:socket_io_common/socket_io_common.dart.

Health suggestions

Fix lib/src/util/event_emitter.dart. (-8.63 points)

Analysis of lib/src/util/event_emitter.dart reported 18 hints, including:

line 15 col 1: Prefer using /// for doc comments.

line 20 col 1: Prefer using /// for doc comments.

line 24 col 3: Prefer using /// for doc comments.

line 29 col 3: Prefer using /// for doc comments.

line 34 col 3: Prefer using /// for doc comments.

Fix lib/src/engine/parser/parser.dart. (-8.17 points)

Analysis of lib/src/engine/parser/parser.dart reported 17 hints, including:

line 26 col 37: Avoid const keyword.

line 36 col 40: Avoid const keyword.

line 47 col 24: Avoid const keyword.

line 92 col 3: Prefer using /// for doc comments.

line 105 col 21: Unnecessary new keyword.

Fix lib/src/parser/parser.dart. (-8.17 points)

Analysis of lib/src/parser/parser.dart reported 17 hints, including:

line 27 col 1: Prefer using /// for doc comments.

line 44 col 33: Unnecessary new keyword.

line 46 col 3: Prefer using /// for doc comments.

line 67 col 3: Prefer using /// for doc comments.

line 104 col 1: Prefer using /// for doc comments.

Fix lib/src/engine/parser/wtf8.dart. (-3.45 points)

Analysis of lib/src/engine/parser/wtf8.dart reported 7 hints, including:

line 1 col 1: Prefer using /// for doc comments.

line 58 col 14: Unnecessary new keyword.

line 63 col 16: Unnecessary new keyword.

line 66 col 16: Unnecessary new keyword.

line 70 col 16: Unnecessary new keyword.

Fix lib/socket_io_common.dart. (-0.50 points)

Analysis of lib/socket_io_common.dart reported 1 hint:

line 1 col 1: Prefer using /// for doc comments.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and socket_io_common.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
logging ^0.11.3+2 0.11.3+2
Dev dependencies
test ^1.0.0