user_profile 0.1.23-nullsafety
user_profile: ^0.1.23-nullsafety copied to clipboard

A shared library that is responsible for the user profile displayed on both apps.

2
likes
90/ 130
pub points
73%
popularity

We analyzed this package on Oct 26, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 35 out of 215 API elements (16.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:user_profile/add_contact.dart that imports:
  • package:user_profile/helpers.dart that imports:
  • package:app_wrapper/app_wrapper.dart that imports:
  • package:app_wrapper/src/device_capabilities.dart that imports:
  • package:local_auth/local_auth.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/constants.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
app_wrapper^0.1.210.1.280.1.28
async_redux^12.0.012.0.013.0.6
debug_logger^0.0.230.0.230.0.23
domain_objects^0.0.26-nullsafety0.0.31-nullsafety0.0.31-nullsafety
dotted_border^2.0.02.0.0+12.0.0+1
flutterflutter0.0.00.0.0
flutter_graphql_client^0.1.230.1.230.1.23
http^0.13.30.13.40.13.4
material_design_icons_flutter^5.0.5955-rc.15.0.62955.0.6295
rxdart^0.27.10.27.20.27.2
shared_themes^0.1.00.1.20.1.2
shared_ui_components^0.1.34-nullsafety0.1.39-nullsafety0.1.39-nullsafety
webview_flutter^2.0.102.1.22.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.030.0.0
analyzer-1.7.22.7.0
args-2.3.02.3.0
async-2.8.22.8.2
build-2.1.12.1.1
build_config-1.0.01.0.0
camera-0.8.1+70.9.4+3
camera_platform_interface-2.1.12.1.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
checked_yaml-2.0.12.0.1
cli_util-0.3.50.3.5
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
cross_file-0.3.1+50.3.1+5
crypto-3.0.13.0.1
dart_style-2.1.12.2.0
dartz-0.10.00.10.0
fast_immutable_collections-5.1.37.0.3
ffi-1.1.21.1.2
file-6.1.26.1.2
file_picker-3.0.44.1.6
flutter_image_compress-1.1.01.1.0
flutter_plugin_android_lifecycle-2.0.42.0.4
flutter_spinkit-5.1.05.1.0
flutter_svg-0.22.00.23.0+1
flutter_web_plugins-0.0.00.0.0
freezed-0.14.20.15.0+1
freezed_annotation-0.14.30.15.0
glob-2.0.22.0.2
google_fonts-2.1.02.1.0
gql-0.13.00.13.0
http_parser-4.0.04.0.0
image_picker-0.8.4+30.8.4+3
image_picker_for_web-2.1.42.1.4
image_picker_platform_interface-2.4.12.4.1
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-4.1.04.3.0
json_serializable-4.1.46.0.1
local_auth-1.1.81.1.8
logger-1.1.01.1.0
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
misc_utilities-0.1.29-nullsafety0.1.29-nullsafety
package_config-2.0.22.0.2
path-1.8.01.8.0
path_drawing-0.5.1+10.5.1+1
path_parsing-0.2.10.2.1
path_provider-2.0.52.0.5
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
pin_code_text_field-1.8.01.8.0
pin_input_text_field-4.1.14.1.1
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
pub_semver-2.1.02.1.0
pubspec_parse-1.1.01.1.0
quiver-3.0.1+13.0.1+1
sky_engine-0.0.990.0.99
sms_autofill-2.2.02.2.0
source_gen-1.0.31.1.1
source_span-1.8.11.8.1
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
stack_trace-1.10.01.10.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher-6.0.126.0.12
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.42.0.4
url_launcher_windows-2.0.22.0.2
vector_math-2.1.02.1.1
watcher-1.0.11.0.1
weak_map-2.0.32.0.3
webview_flutter_android-2.0.152.0.15
webview_flutter_platform_interface-1.2.01.2.0
webview_flutter_wkwebview-2.0.142.0.14
win32-2.2.102.2.10
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^12.0.0` on async_redux does not support the stable version `13.0.4`.

Try running dart pub upgrade --major-versions async_redux to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.