stream_video_push_notification 0.4.2 copy "stream_video_push_notification: ^0.4.2" to clipboard
stream_video_push_notification: ^0.4.2 copied to clipboard

Adds push notification support for Stream Video, a service for building video calls, audio rooms, and live-streaming applications.

3
likes
140/ 160
pub points
89%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

45 out of 112 API elements (40.2 %) have documentation comments.

Some symbols that are missing documentation: stream_video_push_notification, stream_video_push_notification.AndroidParams.AndroidParams.fromJson, stream_video_push_notification.AndroidParams.toJson, stream_video_push_notification.IOSParams.audioSessionActive, stream_video_push_notification.IOSParams.audioSessionMode.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:stream_video_push_notification/stream_video_push_notification.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:stream_video_push_notification/stream_video_push_notification.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:stream_video_push_notification/stream_video_push_notification.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:stream_video_push_notification/stream_video_push_notification.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:stream_video_push_notification/stream_video_push_notification.dart that imports:
  • package:stream_video_push_notification/src/stream_video_push_notification.dart that imports:
  • package:stream_video/stream_video.dart that imports:
  • package:stream_video/src/stream_video.dart that imports:
  • package:stream_video/src/core/client_state.dart that imports:
  • package:stream_video/src/call/call.dart that imports:
  • package:stream_video/src/call/session/call_session_factory.dart that imports:
  • package:stream_video/src/call/session/call_session.dart that imports:
  • package:stream_video/src/sfu/ws/sfu_ws.dart that imports:
  • package:stream_video/src/ws/health/health_monitor.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:stream_video_push_notification/stream_video_push_notification.dart that imports:
  • package:stream_video_push_notification/src/stream_video_push_notification.dart that imports:
  • package:stream_video/stream_video.dart that imports:
  • package:stream_video/src/stream_video.dart that imports:
  • package:stream_video/src/core/client_state.dart that imports:
  • package:stream_video/src/call/call.dart that imports:
  • package:stream_video/src/call/session/call_session_factory.dart that imports:
  • package:stream_video/src/call/session/call_session.dart that imports:
  • package:stream_video/src/sfu/ws/sfu_ws.dart that imports:
  • package:stream_video/src/ws/health/health_monitor.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.17.1 1.18.0 1.19.0
firebase_core ^2.15.0 2.32.0 3.1.0
firebase_messaging ^14.6.6 14.9.4 15.0.1
flutter flutter 0.0.0 0.0.0
flutter_callkit_incoming ^2.0.4 2.0.4+1 2.0.4+1
json_annotation ^4.8.0 4.9.0 4.9.0
meta ^1.9.1 1.12.0 1.15.0
plugin_platform_interface ^2.1.6 2.1.8 2.1.8
rxdart ^0.27.7 0.27.7 0.28.0
stream_video ^0.4.2 0.4.2 0.4.2
uuid ^4.2.1 4.4.0 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.35 1.3.37
args - 2.5.0 2.5.0
asn1lib - 1.5.3 1.5.3
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
connectivity_plus - 6.0.3 6.0.3
connectivity_plus_platform_interface - 2.0.0 2.0.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
crypto_keys - 0.3.0+1 0.3.0+1
dart_webrtc - 1.4.6+hotfix.1 1.4.6+hotfix.1
dbus - 0.7.10 0.7.10
device_info_plus - 10.1.0 10.1.0
device_info_plus_platform_interface - 7.0.0 7.0.0
equatable - 2.0.5 2.0.5
fake_async - 1.3.1 1.3.1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
firebase_core_platform_interface - 5.1.0 5.1.0
firebase_core_web - 2.17.2 2.17.2
firebase_messaging_platform_interface - 4.5.37 4.5.39
firebase_messaging_web - 3.8.7 3.8.9
fixnum - 1.1.0 1.1.0
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
flutter_webrtc - 0.10.8 0.10.8
globbing - 1.0.0 1.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
internet_connection_checker - 1.0.0+1 1.0.0+1
intl - 0.19.0 0.19.0
jose - 0.3.4 0.3.4
js - 0.7.1 0.7.1
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
nm - 0.5.0 0.5.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.5 2.2.5
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.5 3.1.5
platform_detect - 2.0.11 2.0.11
pointycastle - 3.9.1 3.9.1
protobuf - 3.1.0 3.1.0
pub_semver - 2.1.4 2.1.4
quiver - 3.2.1 3.2.1
sdp_transform - 0.3.2 0.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
state_notifier - 1.0.0 1.0.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
system_info2 - 4.0.0 4.0.0
tart - 0.5.1 0.5.1
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.2
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.4
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
webrtc_interface - 1.2.0 1.2.0
win32 - 5.5.1 5.5.1
win32_registry - 1.1.3 1.1.3
x509 - 0.2.4+2 0.2.4+2
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^2.15.0` on firebase_core does not support the stable version `3.0.0`, that was published 10 days ago.

When firebase_core is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions firebase_core to update the constraint.

The constraint `^14.6.6` on firebase_messaging does not support the stable version `15.0.0`, that was published 10 days ago.

When firebase_messaging is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions firebase_messaging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.