pigation 1.0.29
pigation: ^1.0.29 copied to clipboard

An irrigation and out door lighting controller for the Raspbery PI.

0
likes
75/ 130
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 75 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:29:58

   ╷
29 │ The following install guide assumes that you are running <a href="http://raspbian.org/">raspbian</a> (an install option from noobs).</p>
   │                                                          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.21.6.02.3.0
dcli^0.40.00.40.51.14.1
github^7.0.07.0.48.2.5
nginx_le_shared^5.0.05.0.348.0.0
path^1.6.41.8.01.8.0
pub_release^4.0.04.0.47.1.17
settings_yaml^2.1.02.1.53.3.1
uuid^2.0.42.2.23.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.6
async-2.8.22.8.2
basic_utils-2.7.13.9.1
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
cron-0.2.40.4.0
crypto-2.1.53.0.1
csv-4.1.05.0.1
equatable-1.2.62.0.3
ffi-0.1.31.1.2
file-5.2.16.1.2
file_utils-0.1.41.0.1
glob-1.2.02.0.2
globbing-0.3.11.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
ini-2.1.02.1.0
instant-0.3.3+10.4.1
intl-0.16.10.17.0
isolate-2.1.12.1.1
js-0.6.30.6.3
json_annotation-3.1.14.4.0
logger-0.9.41.1.0
logging-0.11.41.0.2
mailer-3.3.05.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
mime-0.9.71.0.1
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
pedantic-1.11.11.11.1
petitparser-3.1.04.4.0
pointycastle-2.0.13.4.0
posix-1.3.42.2.2
pub_semver-1.4.42.1.0
public_suffix-1.2.13.0.0
pubspec-0.1.52.0.1
punycode-0.1.01.0.0
quiver-2.1.53.0.1+1
random_string-2.3.12.3.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
system_info-0.1.31.0.1
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uri-0.11.41.0.0
validators-2.0.13.0.0
vin_decoder-0.1.4+10.1.4+1
xml-4.5.15.3.1
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^1.5.2` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.40.0` on dcli does not support the stable version `0.41.0`.

Try running dart pub upgrade --major-versions dcli to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
75
pub points
0%
popularity

An irrigation and out door lighting controller for the Raspbery PI.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

args, dcli, github, nginx_le_shared, path, pub_release, settings_yaml, uuid

More

Packages that depend on pigation