strings 0.1.0

strings #

Version: 0.1.0

The 'strings' is a helper for the string transformations which can be useful in the code generators (such as 'camelize', 'escape', 'underscore' etc).

Currently supports the following methods:

  • camelize
  • capitalize
  • escape
  • isLowerCase
  • isUpperCase
  • join
  • printable
  • reverse
  • startsWithLowerCase
  • startsWithUpperCase
  • toUnicode
  • underscore

Other useful methods will be added soon...

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  strings: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:strings/strings.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Sep 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21


Detected platforms: Flutter, other

Primary library: package:strings/strings.dart with components: io.

Health suggestions

Fix lib/src/strings.dart. (-10.89 points)

Analysis of lib/src/strings.dart reported 23 hints, including:

line 25 col 11: The declaration '_VALID' isn't referenced.

line 34 col 1: Prefer using /// for doc comments.

line 46 col 7: Use isEmpty instead of length

line 100 col 1: Prefer using /// for doc comments.

line 112 col 7: Use isEmpty instead of length

Maintenance issues and suggestions

Provide a file named (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (lists, unicode).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and strings.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is getting outdated. (-5.75 points)

The package was last published 55 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
lists ^0.0.23 0.0.23 0.1.3
unicode ^0.1.0 0.1.0 0.2.1
Dev dependencies
test ^1.3.0