mmoo_base_recharge 1.2.0+3
mmoo_base_recharge: ^1.2.0+3 copied to clipboard

A new Flutter module.

1
likes
70/ 130
pub points
0%
popularity

We analyzed this package 2 hours ago, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/seemelala/flutter_base_recharge was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 233 API elements (10.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Android`.

Because:

  • package:mmoo_base_recharge/dao/recharge_dao.dart that imports:
  • package:mmoo_base/dao/base_dao.dart that imports:
  • package:sp_util/sp_util.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

lib/dao/recharge_dao.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/entity/recharge_list_entity.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.15.01.15.0
connectivity^3.0.63.0.63.0.6
crypto^3.0.13.0.13.0.1
flutterflutter0.0.00.0.0
in_app_purchase^1.0.91.0.92.0.0
in_app_purchase_android^0.1.60.1.60.2.1
in_app_purchase_ios^0.1.40.1.40.2.0+1
mmoo_base^1.2.0+51.2.0+61.2.0+6
sp_util^2.0.32.0.32.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
android_intent-2.0.22.0.2
args-2.3.02.3.0
asn1lib-1.0.31.0.3
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
connectivity_for_web-0.4.0+10.4.0+1
connectivity_macos-0.2.1+20.2.1+2
connectivity_platform_interface-2.0.12.0.1
convert-3.0.13.0.1
date_format-2.0.42.0.4
device_info-2.0.32.0.3
device_info_platform_interface-2.0.12.0.1
dio-4.0.44.0.4
encrypt-5.0.15.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_cache_manager-3.3.03.3.0
flutter_image_compress-1.1.01.1.0
flutter_screenutil-5.0.15.0.1
flutter_secure_storage-5.0.25.0.2
flutter_secure_storage_linux-1.1.01.1.0
flutter_secure_storage_macos-1.1.01.1.0
flutter_secure_storage_platform_interface-1.0.01.0.0
flutter_secure_storage_web-1.0.21.0.2
flutter_secure_storage_windows-1.1.21.1.2
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
in_app_purchase_platform_interface-1.3.01.3.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-4.4.04.4.0
meta-1.7.01.7.0
package_info-2.0.22.0.2
path-1.8.01.8.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.42.0.4
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
permission_handler-8.3.08.3.0
permission_handler_platform_interface-3.7.03.7.0
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
pointycastle-3.4.03.4.0
process-4.2.44.2.4
rxdart-0.27.30.27.3
shared_preferences-2.0.92.0.9
shared_preferences_android-2.0.92.0.9
shared_preferences_ios-2.0.82.0.8
shared_preferences_linux-2.0.32.0.3
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.32.0.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.12.0.1
sqflite_common-2.0.1+12.0.1+1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.0.9` on in_app_purchase does not support the stable version `2.0.0`, that was published 4 days ago.

When in_app_purchase is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions in_app_purchase to update the constraint.

The constraint `^0.1.6` on in_app_purchase_android does not support the stable version `0.2.0`, that was published 18 days ago.

When in_app_purchase_android is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions in_app_purchase_android to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.