hucel_core 0.3.4 copy "hucel_core: ^0.3.4" to clipboard
hucel_core: ^0.3.4 copied to clipboard

This My Best Core Components and Uniq Code variants And Usefull Widgets

1
likes
50/ 160
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 50 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: hucel_core,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Could not accept branch name: 0.3.3.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

96 out of 1171 API elements (8.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: hucel_core, hucel_core.AddOperator, hucel_core.AddOperator.operator +, hucel_core.AddRemoveItems, hucel_core.AddRemoveItems.operator +.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:hucel_core/hucel_core.dart that imports:
  • package:hucel_core/src/widget/random_image.dart that imports:
  • package:hucel_core/src/extension/string_extension.dart that imports:
  • package:share_plus/share_plus.dart that imports:
  • package:share_plus/src/share_plus_linux.dart that imports:
  • package:url_launcher_linux/url_launcher_linux.dart that declares support for platforms: Linux.
Package does not support platform `Linux`.

Because:

  • package:hucel_core/hucel_core.dart that imports:
  • package:hucel_core/src/widget/random_image.dart that imports:
  • package:hucel_core/src/extension/string_extension.dart that imports:
  • package:share_plus/share_plus.dart that imports:
  • package:share_plus/src/share_plus_windows.dart that imports:
  • package:url_launcher_windows/url_launcher_windows.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:hucel_core/hucel_core.dart that imports:
  • package:hucel_core/src/widget/random_image.dart that imports:
  • package:hucel_core/src/extension/string_extension.dart that imports:
  • package:share_plus/share_plus.dart that imports:
  • package:share_plus/src/share_plus_windows.dart that imports:
  • package:url_launcher_windows/url_launcher_windows.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:hucel_core/hucel_core.dart that imports:
  • package:hucel_core/src/widget/random_image.dart that imports:
  • package:hucel_core/src/extension/string_extension.dart that imports:
  • package:share_plus/share_plus.dart that imports:
  • package:share_plus/src/share_plus_web.dart that imports:
  • package:share_plus_platform_interface/share_plus_platform_interface.dart that imports:
  • package:share_plus_platform_interface/platform_interface/share_plus_platform.dart that imports:
  • package:share_plus_platform_interface/method_channel/method_channel_share.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:hucel_core/hucel_core.dart that imports:
  • package:hucel_core/src/widget/random_image.dart that imports:
  • package:hucel_core/src/extension/string_extension.dart that imports:
  • package:share_plus/share_plus.dart that imports:
  • package:share_plus/src/share_plus_windows.dart that imports:
  • package:url_launcher_windows/url_launcher_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:hucel_core/hucel_core.dart that imports:
  • package:hucel_core/src/widget/random_image.dart that imports:
  • package:hucel_core/src/extension/string_extension.dart that imports:
  • package:share_plus/share_plus.dart that imports:
  • package:share_plus/src/share_plus_windows.dart that imports:
  • package:url_launcher_windows/url_launcher_windows.dart that declares support for platforms: Windows.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 47 issues. Showing the first 2:

ERROR: The getter 'backgroundColor' isn't defined for the type 'ThemeData'.

lib/src/extension/context_extension.dart:11:38

   ╷
11 │   Color get backgroundColor => theme.backgroundColor;
   │                                      ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/extension/context_extension.dart

ERROR: The getter 'headline1' isn't defined for the type 'TextTheme'.

lib/src/extension/context_extension.dart:20:41

   ╷
20 │   TextStyle? get headline1 => textTheme.headline1;
   │                                         ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/extension/context_extension.dart

failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.9.0 2.11.0 2.11.0
cloud_firestore ^4.2.0 4.17.5 5.1.0
collection ^1.16.0 1.18.0 1.19.0
connectivity_plus ^3.0.2 3.0.6 6.0.3
device_info_plus ^8.0.0 8.2.2 10.1.0
easy_localization ^3.0.1 3.0.7 3.0.7
firebase_auth ^4.2.0 4.20.0 5.1.2
firebase_core ^2.4.0 2.32.0 3.2.0
firebase_messaging ^14.1.4 14.9.4 15.0.3
firebase_storage ^11.0.7 11.7.7 12.1.1
flutter flutter 0.0.0 0.0.0
flutter_facebook_auth ^5.0.6 5.0.11 7.0.1
flutter_mobx ^2.0.6+5 2.2.1+1 2.2.1+1
google_sign_in ^5.4.2 5.4.4 6.2.1
hive ^2.2.3 2.2.3 2.2.3
http ^0.13.5 0.13.6 1.2.1
image_picker ^0.8.6 0.8.9 1.1.2
logger ^1.1.0 1.4.0 2.3.0
lottie ^2.0.0 2.7.0 3.1.2
mask_text_input_formatter ^2.4.0 2.9.0 2.9.0
mime ^1.0.3 1.0.5 1.0.5
mobx ^2.1.3 2.3.3+2 2.3.3+2
package_info_plus ^3.0.2 3.1.2 8.0.0
path_provider ^2.0.11 2.1.3 2.1.3
provider ^6.0.4 6.1.2 6.1.2
rxdart ^0.27.5 0.27.7 0.28.0
share_plus ^6.3.0 6.3.4 9.0.0
shared_preferences ^2.0.15 2.2.3 2.2.3
url_launcher ^6.1.7 6.3.0 6.3.0
webview_flutter ^3.0.4 3.0.4 4.8.0
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.35 1.3.39
archive - 3.6.1 3.6.1
args - 2.5.0 2.5.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
cloud_firestore_platform_interface - 6.2.5 6.2.9
cloud_firestore_web - 3.12.5 4.0.3
connectivity_plus_platform_interface - 1.2.4 2.0.0
cross_file - 0.3.4+1 0.3.4+1
crypto - 3.0.3 3.0.3
dbus - 0.7.10 0.7.10
device_info_plus_platform_interface - 7.0.0 7.0.0
easy_logger - 0.0.2 0.0.2
facebook_auth_desktop - 0.0.9 2.0.0
fake_async - 1.3.1 1.3.1
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
file_selector_linux - 0.9.2+1 0.9.2+1
file_selector_macos - 0.9.4 0.9.4
file_selector_platform_interface - 2.6.2 2.6.2
file_selector_windows - 0.9.3+1 0.9.3+1
firebase_auth_platform_interface - 7.3.0 7.4.2
firebase_auth_web - 5.12.0 5.12.4
firebase_core_platform_interface - 5.1.0 5.1.0
firebase_core_web - 2.17.3 2.17.3
firebase_messaging_platform_interface - 4.5.37 4.5.41
firebase_messaging_web - 3.8.7 3.8.11
firebase_storage_platform_interface - 5.1.22 5.1.26
firebase_storage_web - 3.9.7 3.9.11
fixnum - 1.1.0 1.1.0
flutter_facebook_auth_platform_interface - 4.1.1 6.0.0
flutter_facebook_auth_web - 4.1.1 6.0.0
flutter_localizations - 0.0.0 0.0.0
flutter_plugin_android_lifecycle - 2.0.20 2.0.20
flutter_secure_storage - 8.1.0 9.2.2
flutter_secure_storage_linux - 1.2.1 1.2.1
flutter_secure_storage_macos - 3.1.2 3.1.2
flutter_secure_storage_platform_interface - 1.1.2 1.1.2
flutter_secure_storage_web - 1.2.1 1.2.1
flutter_secure_storage_windows - 2.1.1 3.1.2
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
google_sign_in_android - 6.1.27 6.1.27
google_sign_in_ios - 5.7.6 5.7.6
google_sign_in_platform_interface - 2.4.5 2.4.5
google_sign_in_web - 0.10.2+1 0.12.4+1
http_parser - 4.0.2 4.1.0
image_picker_android - 0.8.12+4 0.8.12+4
image_picker_for_web - 2.2.0 3.0.4
image_picker_ios - 0.8.12 0.8.12
image_picker_linux - 0.2.1+1 0.2.1+1
image_picker_macos - 0.2.1+1 0.2.1+1
image_picker_platform_interface - 2.10.0 2.10.0
image_picker_windows - 0.2.1+1 0.2.1+1
intl - 0.19.0 0.19.0
js - 0.6.7 0.7.1
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
nm - 0.5.0 0.5.0
package_info_plus_platform_interface - 2.0.1 3.0.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.7 2.2.7
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
petitparser - 6.0.2 6.0.2
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
share_plus_platform_interface - 3.4.0 4.0.0
shared_preferences_android - 2.2.3 2.2.3
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.3.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.3
typed_data - 1.3.2 1.3.2
url_launcher_android - 6.3.3 6.3.3
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
uuid - 4.4.2 4.4.2
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.4
web - 0.5.1 0.5.1
webview_flutter_android - 2.10.4 3.16.4
webview_flutter_platform_interface - 1.9.5 2.10.0
webview_flutter_wkwebview - 2.9.5 3.14.0
win32 - 3.1.4 5.5.1
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 17 issues. Showing the first 2:

The constraint `^4.2.0` on cloud_firestore does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

The constraint `^3.0.2` on connectivity_plus does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions connectivity_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 25 errors:

  • UNDEFINED_GETTER - lib/src/extension/context_extension.dart:11:38 - The getter 'backgroundColor' isn't defined for the type 'ThemeData'.
  • UNDEFINED_GETTER - lib/src/extension/context_extension.dart:20:41 - The getter 'headline1' isn't defined for the type 'TextTheme'.
  • UNDEFINED_GETTER - lib/src/extension/context_extension.dart:21:41 - The getter 'headline2' isn't defined for the type 'TextTheme'.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.