carp_context_package 0.21.1
carp_context_package: ^0.21.1 copied to clipboard

CARP context sampling package. Samples location, mobility, activity, weather, air-quality, and geofence.

4
likes
80 / 130
pub points
63 %
popularity

We analyzed this package on May 17, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 176 out of 314 API elements (56.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:carp_context_package/context.dart that imports:
  • package:carp_mobile_sensing/carp_mobile_sensing.dart that imports:
  • package:carp_mobile_sensing/sampling_packages/sensors/sensors.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

lib/src/air_quality/air_quality_datum.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/air_quality/air_quality_measure.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
activity_recognition_flutter^3.0.03.0.1+14.0.1
air_quality^1.2.11.2.1+12.0.0
carp_background_location^1.0.31.0.31.0.3
carp_mobile_sensing^0.21.00.21.40.21.4
flutterflutter0.0.00.0.0
geolocator^6.2.06.2.17.0.3
json_annotation^3.0.03.1.14.0.1
mobility_features^2.0.62.0.6+12.0.6+1
openmhealth_schemas^0.1.4+10.1.4+10.1.4+1
permission_handler^5.0.1+15.1.0+27.1.0
weather^1.2.21.4.02.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.021.0.0
analyzer-0.41.21.5.0
archive-2.0.133.1.2
args-1.6.02.1.0
async-2.6.12.6.1
background_locator-1.6.0+1-beta1.6.0+1-beta
battery-1.0.112.0.1
battery_platform_interface-1.0.02.0.1
boolean_selector-2.1.02.1.0
carp_core-0.21.4+20.21.4+2
characters-1.1.01.1.0
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
collection-1.15.01.15.0
convert-2.1.13.0.0
coverage-0.15.21.0.2
cron-0.2.40.3.0
crypto-2.1.53.0.1
device_apps-1.3.02.1.1
device_info-1.0.02.0.0
device_info_platform_interface-1.0.12.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
file_utils-0.1.41.0.0
flutter_web_plugins-0.0.00.0.0
geolocator_platform_interface-1.0.92.0.2
geolocator_web-1.0.12.0.3
glob-2.0.12.0.1
globbing-0.3.11.0.0
http-0.12.20.13.3
http_multi_server-3.0.13.0.1
http_parser-3.1.44.0.0
io-1.0.01.0.0
js-0.6.30.6.3
light-1.0.12.0.0
location_permissions-3.0.0+13.0.0+1
logging-1.0.11.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime-1.0.01.0.0
node_preamble-1.4.132.0.0
package_config-1.9.32.0.0
package_info-0.4.3+42.0.0
path-1.8.01.8.0
path_provider-1.6.282.0.1
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
pedometer-2.1.03.0.0
permission_handler_platform_interface-2.0.23.3.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
pool-1.5.01.5.0
process-4.2.14.2.1
pub_semver-2.0.02.0.0
screen_state-1.0.12.0.0
sensors-0.4.2+62.0.0
shared_preferences-0.5.12+42.0.5
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
shelf-0.7.91.1.4
shelf_packages_handler-2.0.13.0.0
shelf_static-0.2.9+21.0.0
shelf_web_socket-0.2.4+11.0.1
simple_cluster-0.2.10.3.0
sky_engine-0.0.990.0.99
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stats-1.0.12.0.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
system_info-0.1.31.0.0
term_glyph-1.2.01.2.0
test_api-0.2.190.4.0
test_core-0.3.150.3.24
typed_data-1.3.01.3.0
uuid-2.2.23.0.4
vector_math-2.1.02.1.0
vm_service-6.2.07.0.0
watcher-1.0.01.0.0
web_socket_channel-1.2.02.1.0
webkit_inspection_protocol-1.0.01.0.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^3.0.0` on activity_recognition_flutter does not support the stable version `4.0.0`, that was published 24 days ago.

When activity_recognition_flutter is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions activity_recognition_flutter to update the constraint.

The constraint `^1.2.1` on air_quality does not support the stable version `2.0.0`, that was published 26 days ago.

When air_quality is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions air_quality to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.