location_web 1.0.0

  • Readme
  • Changelog
  • Installing
  • new45

location_web #

The web implementation of location.

Usage #

Import the package #

This package is the endorsed implementation of location for the web platform since version 3.0.0, so it gets automatically added to your dependencies by depending on location: ^3.0.0.

No modifications to your pubspec.yaml should be required in a recent enough version of Flutter (>=1.12.13+hotfix.4):

...
dependencies:
  ...
  location: ^3.0.0
  ...

Once you have location in pubspec.yaml you should be able to use package:location as normal.

1.0.0 26th March 2020 #

  • First release of the Web platform of the Location plugin (huge thanks to long1eu)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  location_web: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:location_web/location_web.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
76
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

We analyzed this package on Mar 26, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Maintenance suggestions

The package description is too short. (-14 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and location_web.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
flutter_web_plugins 0.0.0
http_parser ^3.1.3 3.1.4
js ^0.6.1+1 0.6.1+1
location_platform_interface ^1.0.0 1.0.0
meta ^1.1.8 1.1.8
Transitive dependencies
charcode 1.1.3
collection 1.14.11 1.14.12
path 1.6.4
plugin_platform_interface 1.0.2
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
mockito ^4.1.1