bones_api 1.0.31
bones_api: ^1.0.31 copied to clipboard

Bones_API - A Powerful API backend framework for Dart. Comes with a built-in HTTP Server, routes handler, entity handler, SQL translator, and DB adapters.

6
likes
130/ 130
pub points
61%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/bones_api_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 545 out of 1625 API elements (33.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.2.02.3.02.3.0
async_extension^1.0.91.0.91.0.9
collection^1.15.01.15.01.15.0
crypto^3.0.13.0.13.0.1
dart_spawner^1.0.51.0.51.0.5
hotreloader^3.0.13.0.13.0.1
logging^1.0.11.0.21.0.2
mercury_client^2.1.12.1.12.1.1
mime^1.0.01.0.11.0.1
mysql1^0.19.20.19.20.19.2
petitparser^4.2.04.4.04.4.0
postgres^2.4.1+22.4.1+22.4.1+2
project_template^1.0.21.0.21.0.2
reflection_factory^1.0.161.0.161.0.16
resource_portable^3.0.03.0.03.0.0
shelf^1.2.01.2.01.2.0
yaml^3.1.03.1.03.1.0
yaml_writer^1.0.11.0.11.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-29.0.029.0.0
analyzer-2.6.02.6.0
archive-3.1.63.1.6
async-2.8.22.8.2
buffer-1.1.11.1.1
build-2.1.12.1.1
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
clock-1.1.01.1.0
convert-3.0.13.0.1
dart_style-2.2.02.2.0
enum_to_string-2.0.12.0.1
file-6.1.26.1.2
glob-2.0.22.0.2
http_parser-4.0.04.0.0
intl-0.17.00.17.0
meta-1.7.01.7.0
package_config-2.0.22.0.2
pedantic-1.11.11.11.1
pool-1.5.01.5.0
pub_semver-2.1.02.1.0
sasl_scram-0.1.00.1.0
saslprep-1.0.21.0.2
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
swiss_knife-3.0.83.0.8
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
unorm_dart-0.2.00.2.0
vm_service-6.2.07.3.0
watcher-1.0.11.0.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Dart 2.14.3.

6
likes
130
pub points
61%
popularity

Bones_API - A Powerful API backend framework for Dart. Comes with a built-in HTTP Server, routes handler, entity handler, SQL translator, and DB adapters.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Artistic-2.0 (LICENSE)

Dependencies

args, async_extension, collection, crypto, dart_spawner, hotreloader, logging, mercury_client, mime, mysql1, petitparser, postgres, project_template, reflection_factory, resource_portable, shelf, yaml, yaml_writer

More

Packages that depend on bones_api