bones_api 1.0.31
bones_api: ^1.0.31 copied to clipboard

Bones_API - A Powerful API backend framework for Dart. Comes with a built-in HTTP Server, routes handler, entity handler, SQL translator, and DB adapters.

Use this package as an executable

Install it

You can install the package from the command line:

dart pub global activate bones_api

Use it

The package has the following executables:

$ bones_api

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add bones_api

With Flutter:

 $ flutter pub add bones_api

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  bones_api: ^1.0.31

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:bones_api/bones_api.dart';
6
likes
130
pub points
60%
popularity

Bones_API - A Powerful API backend framework for Dart. Comes with a built-in HTTP Server, routes handler, entity handler, SQL translator, and DB adapters.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Artistic-2.0 (LICENSE)

Dependencies

args, async_extension, collection, crypto, dart_spawner, hotreloader, logging, mercury_client, mime, mysql1, petitparser, postgres, project_template, reflection_factory, resource_portable, shelf, yaml, yaml_writer

More

Packages that depend on bones_api