build_cli_annotations 1.2.0

  • Readme
  • Changelog
  • Installing
  • 86

Contains annotations for package:build_cli.

See that package for more information.

1.2.0 #

  • Update the constraint on package:args to '>=1.5.0 <1.7.0'.
  • Require Dart SDK >=2.2.0 <3.0.0.

1.1.0 #

  • Added provideDefaultToOverride to CliOption to allow users to provide an override to defaultsTo.

1.0.1 #

  • Support nullable annotation

1.0.0 #

  • Update the version of package:args to '>=1.5.0 <1.6.0'.

0.1.2+1 #

  • Support Dart 2 stable.

0.1.2 #

  • Added convert to CliOption.

0.1.1 #

  • Added valueHelp to CliOption.

0.1.0 #

  • First release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  build_cli_annotations: ^1.2.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:build_cli_annotations/build_cli_annotations.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Mar 30, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and build_cli_annotations.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
args >=1.5.0 <1.7.0 1.6.0