build_cli_annotations 1.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 81

Contains annotations for package:build_cli.

See that package for more information.

1.1.0 #

  • Added provideDefaultToOverride to CliOption to allow users to provide an override to defaultsTo.

1.0.1 #

  • Support nullable annotation

1.0.0 #

  • Update the version of package:args to '>=1.5.0 <1.6.0'.

0.1.2+1 #

  • Support Dart 2 stable.

0.1.2 #

  • Added convert to CliOption.

0.1.1 #

  • Added valueHelp to CliOption.

0.1.0 #

  • First release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  build_cli_annotations: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:build_cli_annotations/build_cli_annotations.dart';
  
Version Uploaded Documentation Archive
1.1.0 Mar 7, 2019 Go to the documentation of build_cli_annotations 1.1.0 Download build_cli_annotations 1.1.0 archive
1.0.1 Nov 27, 2018 Go to the documentation of build_cli_annotations 1.0.1 Download build_cli_annotations 1.0.1 archive
1.0.0 Aug 3, 2018 Go to the documentation of build_cli_annotations 1.0.0 Download build_cli_annotations 1.0.0 archive
0.1.2+1 Jul 23, 2018 Go to the documentation of build_cli_annotations 0.1.2+1 Download build_cli_annotations 0.1.2+1 archive
0.1.2 Apr 19, 2018 Go to the documentation of build_cli_annotations 0.1.2 Download build_cli_annotations 0.1.2 archive
0.1.1 Apr 17, 2018 Go to the documentation of build_cli_annotations 0.1.1 Download build_cli_annotations 0.1.1 archive
0.1.0 Mar 29, 2018 Go to the documentation of build_cli_annotations 0.1.0 Download build_cli_annotations 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
66
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
81
Learn more about scoring.

We analyzed this package on Jun 4, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.1
  • pana: 0.12.17

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:build_cli_annotations/build_cli_annotations.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and build_cli_annotations.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
args >=1.5.0 <1.6.0 1.5.2