Contains annotations for
See that package for more information.
- Update the constraint on
- Require Dart SDK
CliOptionto allow users to provide an override to
- Support nullable annotation
- Update the version of
- Support Dart 2 stable.
- First release.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: build_cli_annotations: ^1.2.0
2. Install it
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Mar 30, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.1
- pana: 0.13.6
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
build_cli_annotations.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=2.2.0 <3.0.0|