swiss_knife 2.1.2

  • Readme
  • Changelog
  • Installing
  • 63

Swiss Knife #

Dart useful tools: collections, math, date, etc...

Usage #

A simple usage example:

import 'package:swiss_knife/swiss_knife.dart';

class User {

  final EventStream<String> onNotification = new EventStream() ;

  void notify(String msg) {
    onNotification.add(msg) ;
  }

}

void main() {

  User user = new User() ;

  user.onNotification.listen((msg) {
    print("NOTIFICATION> $msg") ;
  });

}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Author #

Graciliano M. Passos: gmpassos@GitHub.

License #

Dart free & open-source license.

2.1.2 #

  • Add LocalesManager.onDefineLocale and LocalesManager.onDefineLocaleGlobal

2.1.1 #

  • Small fixes.

2.1.0 #

  • Added Authorization and Credential/Token handling to REST Client.

2.0.0 #

  • Update to Dart 2.0.1 and small fixes. Now able to import only utils (swiss_knife_utils.dart)

1.0.1 #

  • Fix swiss_knife_browser.dart exports.

1.0.0 #

  • Added events example.
  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  swiss_knife: ^2.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:swiss_knife/swiss_knife.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
33
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
63
Learn more about scoring.

We analyzed this package on Nov 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:swiss_knife/swiss_knife.dart.

Health suggestions

Fix lib/src/utils.dart. (-0.50 points)

Analysis of lib/src/utils.dart reported 1 hint:

line 515 col 10: Unnecessary cast.

Format lib/src/locales.dart.

Run dartfmt to format lib/src/locales.dart.

Format lib/src/locales_browser.dart.

Run dartfmt to format lib/src/locales_browser.dart.

Format lib/src/rest_client.dart.

Run dartfmt to format lib/src/rest_client.dart.

Format lib/src/utils_browser.dart.

Run dartfmt to format lib/src/utils_browser.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (intl).

The package description is too short. (-10 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and swiss_knife.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.1 <3.0.0
intl ^0.15.7 0.15.8 0.16.0
Transitive dependencies
path 1.6.4
Dev dependencies
test ^1.5.1