wasm_interop 1.0.0-dev.1.0

  • Readme
  • Changelog
  • Installing
  • 54

WebAssembly JS API Bindings for Dart #

Specification #

Running tests #

Release mode on Chrome and Firefox:

$ pub run build_runner test -- --release -p "chrome,firefox"

Debug mode (DDC) on Chrome and node:

$ pub run build_runner test -- -p "chrome,node"

1.0.0-dev.1.0 #

  • Implemented WebAssembly.Global interface.

  • Updated to the latest SDK.

1.0.0-dev.0.0 #

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  wasm_interop: ^1.0.0-dev.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:wasm_interop/wasm_interop.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Maintenance suggestions

Package is getting outdated. (-17.26 points)

The package was last published 61 weeks ago.

The package description is too short. (-17 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and wasm_interop.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution; their API can change in breaking ways.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
js ^0.6.1 0.6.1+1
meta ^1.1.5 1.1.8
Dev dependencies
build_node_compilers ^0.2.1
build_runner ^1.2.0
build_test any
build_web_compilers ^1.0.0
test ^1.5.2