blip_ds 0.1.1 copy "blip_ds: ^0.1.1" to clipboard
blip_ds: ^0.1.1 copied to clipboard

PlatformiOS

Blip Design System for Flutter.

6
likes
120/ 160
pub points
33%
popularity

We analyzed this package 6 hours ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

225 out of 1159 API elements (19.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: blip_ds, blip_ds.DSApplicationJsonMessageBubble, blip_ds.DSApplicationJsonMessageBubble.DSApplicationJsonMessageBubble, blip_ds.DSApplicationJsonMessageBubble.align, blip_ds.DSApplicationJsonMessageBubble.avatarConfig.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ iOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:blip_ds/blip_ds.dart that imports:
  • package:blip_ds/src/widgets/tags/ds_input_chip.widget.dart that imports:
  • package:blip_ds/src/widgets/tags/tag_editor/tag_editor.dart that imports:
  • package:pointer_interceptor/pointer_interceptor.dart that declares support for platforms: iOS, Web.
Package does not support platform `Windows`.

Because:

  • package:blip_ds/blip_ds.dart that imports:
  • package:blip_ds/src/widgets/utils/ds_user_avatar.widget.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:blip_ds/blip_ds.dart that imports:
  • package:blip_ds/src/widgets/utils/ds_user_avatar.widget.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `macOS`.

Because:

  • package:blip_ds/blip_ds.dart that imports:
  • package:blip_ds/src/widgets/utils/ds_group_card.widget.dart that imports:
  • package:blip_ds/src/widgets/utils/ds_card.widget.dart that imports:
  • package:blip_ds/src/widgets/chat/ds_location_message_bubble.widget.dart that imports:
  • package:map_launcher/map_launcher.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:blip_ds/blip_ds.dart that imports:
  • package:blip_ds/src/widgets/utils/ds_user_avatar.widget.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `iOS`.

Because:

  • package:blip_ds/blip_ds.dart that imports:
  • package:blip_ds/src/widgets/chat/video/ds_video_player.widget.dart that imports:
  • package:blip_ds/src/controllers/ds_video_player.controller.dart that imports:
  • package:chewie/chewie.dart that imports:
  • package:chewie/src/material/material_desktop_controls.dart that imports:
  • package:chewie/src/chewie_player.dart that imports:
  • package:wakelock_plus/wakelock_plus.dart that imports:
  • package:wakelock_plus/src/wakelock_plus_windows_plugin.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 50 issues. Showing the first 2:

INFO: 'WillPopScope' is deprecated and shouldn't be used. Use PopScope instead. This feature was deprecated after v3.12.0-1.0.pre.

lib/src/services/ds_bottom_sheet.service.dart:128:23

    ╷
128 │       builder: (_) => WillPopScope(
    │                       ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/services/ds_bottom_sheet.service.dart

INFO: 'WillPopScope.new' is deprecated and shouldn't be used. Use PopScope instead. This feature was deprecated after v3.12.0-1.0.pre.

lib/src/services/ds_bottom_sheet.service.dart:128:23

    ╷
128 │       builder: (_) => WillPopScope(
    │                       ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/services/ds_bottom_sheet.service.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cached_network_image ^3.2.1 3.3.1 3.3.1
chewie ^1.3.4 1.8.1 1.8.1
crypto ^3.0.3 3.0.3 3.0.3
debounce_throttle ^2.0.0 2.0.0 2.0.0
dio ^5.2.1+1 5.4.3+1 5.4.3+1
dotted_border ^2.0.0+3 2.1.0 2.1.0
ffmpeg_kit_flutter_full_gpl ^6.0.3 6.0.3 6.0.3
file_sizes ^1.0.6 1.0.6 1.0.6
flutter flutter 0.0.0 0.0.0
flutter_image_compress ^2.1.0 2.3.0 2.3.0
flutter_spinkit ^5.1.0 5.2.1 5.2.1
flutter_svg ^2.0.7 2.0.10+1 2.0.10+1
get ^4.6.5 4.6.6 4.6.6
just_audio ^0.9.35 0.9.38 0.9.38
linkify ^5.0.0 5.0.0 5.0.0
map_launcher ^3.1.0 3.3.1 3.3.1
mask_text_input_formatter ^2.4.0 2.9.0 2.9.0
mime ^1.0.4 1.0.5 1.0.5
open_filex ^4.3.2 4.4.0 4.4.0
path ^1.8.1 1.9.0 1.9.0
path_provider ^2.1.1 2.1.3 2.1.3
phone_number ^2.0.1 2.1.0 2.1.0
pinch_zoom ^2.0.0 2.0.0 2.0.0
pointer_interceptor ^0.10.1 0.10.1+1 0.10.1+1
rxdart ^0.27.4 0.27.7 0.27.7
simple_animations ^5.0.2 5.0.2 5.0.2
simple_link_preview ^2.0.0 2.0.0 2.0.0
sticky_headers ^0.3.0 0.3.0+2 0.3.0+2
url_launcher ^6.1.5 6.3.0 6.3.0
video_compress ^3.1.2 3.1.2 3.1.2
video_player ^2.7.0 2.8.7 2.8.7
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
audio_session - 0.1.19 0.1.19
cached_network_image_platform_interface - 4.0.0 4.0.0
cached_network_image_web - 1.2.0 1.2.0
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
cross_file - 0.3.4+1 0.3.4+1
csslib - 1.0.0 1.0.0
cupertino_icons - 1.0.8 1.0.8
dbus - 0.7.10 0.7.10
ffi - 2.1.2 2.1.2
ffmpeg_kit_flutter_platform_interface - 0.2.1 0.2.1
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_cache_manager - 3.3.2 3.3.2
flutter_image_compress_common - 1.0.5 1.0.5
flutter_image_compress_macos - 1.0.2 1.0.2
flutter_image_compress_ohos - 0.0.3 0.0.3
flutter_image_compress_platform_interface - 1.0.5 1.0.5
flutter_image_compress_web - 0.1.4+1 0.1.4+1
flutter_web_plugins - 0.0.0 0.0.0
html - 0.15.4 0.15.4
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
js - 0.7.1 0.7.1
just_audio_platform_interface - 4.3.0 4.3.0
just_audio_web - 0.4.11 0.4.11
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
metadata_fetch_plus - 1.0.0 1.0.0
nested - 1.0.0 1.0.0
octo_image - 2.0.0 2.0.0
package_info_plus - 8.0.0 8.0.0
package_info_plus_platform_interface - 3.0.0 3.0.0
path_drawing - 1.0.1 1.0.1
path_parsing - 1.0.1 1.0.1
path_provider_android - 2.2.5 2.2.5
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
pointer_interceptor_ios - 0.10.1 0.10.1
pointer_interceptor_platform_interface - 0.10.0+1 0.10.0+1
pointer_interceptor_web - 0.10.2 0.10.2
provider - 6.1.2 6.1.2
simple_observable - 2.0.0 2.0.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
sqflite - 2.3.3+1 2.3.3+1
sqflite_common - 2.5.4 2.5.4
string_scanner - 1.2.0 1.2.0
string_validator - 1.1.0 1.1.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
universal_html - 2.2.4 2.2.4
universal_io - 2.2.2 2.2.2
url_launcher_android - 6.3.3 6.3.3
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
uuid - 4.4.0 4.4.0
vector_graphics - 1.1.11+1 1.1.11+1
vector_graphics_codec - 1.1.11+1 1.1.11+1
vector_graphics_compiler - 1.1.11+1 1.1.11+1
vector_math - 2.1.4 2.1.4
video_player_android - 2.5.0 2.5.0
video_player_avfoundation - 2.6.1 2.6.1
video_player_platform_interface - 6.2.2 6.2.2
video_player_web - 2.3.1 2.3.1
wakelock_plus - 1.2.5 1.2.5
wakelock_plus_platform_interface - 1.2.1 1.2.1
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.