amplify_push_notifications_pinpoint 1.8.0 copy "amplify_push_notifications_pinpoint: ^1.8.0" to clipboard
amplify_push_notifications_pinpoint: ^1.8.0 copied to clipboard

The Amplify Flutter Push Notifications category plugin using the AWS Pinpoint provider.

4
likes
130/ 140
pub points
90%
popularity

We analyzed this package 36 hours ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/aws-amplify/amplify-flutter/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4 out of 15 API elements (26.7 %) have documentation comments.

Some symbols that are missing documentation: amplify_push_notifications_pinpoint, amplify_push_notifications_pinpoint.AmplifyPushNotificationsPinpoint.getBadgeCount, amplify_push_notifications_pinpoint.AmplifyPushNotificationsPinpoint.getPermissionStatus, amplify_push_notifications_pinpoint.AmplifyPushNotificationsPinpoint.identifyUser, amplify_push_notifications_pinpoint.AmplifyPushNotificationsPinpoint.launchNotification.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:amplify_push_notifications_pinpoint/amplify_push_notifications_pinpoint.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:amplify_push_notifications_pinpoint/amplify_push_notifications_pinpoint.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:amplify_push_notifications_pinpoint/amplify_push_notifications_pinpoint.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:amplify_push_notifications_pinpoint/amplify_push_notifications_pinpoint.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:amplify_push_notifications_pinpoint/amplify_push_notifications_pinpoint.dart that imports:
  • package:amplify_push_notifications_pinpoint/src/push_notifications_background_processing.dart that imports:
  • package:amplify_push_notifications/amplify_push_notifications.dart that imports:
  • package:amplify_push_notifications/src/amplify_push_notifications_impl.dart that imports:
  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/utils/file_key_value_store.dart that declares support for platforms: iOS, Windows, Linux, macOS, Web.
Package does not support platform `iOS`.

Because:

  • package:amplify_push_notifications_pinpoint/amplify_push_notifications_pinpoint.dart that imports:
  • package:amplify_push_notifications_pinpoint/src/push_notifications_background_processing.dart that imports:
  • package:amplify_push_notifications/amplify_push_notifications.dart that imports:
  • package:amplify_push_notifications/src/amplify_push_notifications_impl.dart that imports:
  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/amplify_secure_storage_dart.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/platforms/amplify_secure_storage_windows.dart that imports:
  • package:amplify_secure_storage_dart/src/ffi/win32/data_protection.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
amplify_analytics_pinpoint >=1.8.0 <1.9.0 1.8.0 1.8.0
amplify_analytics_pinpoint_dart >=0.3.8 <0.4.0 0.3.8 0.3.8
amplify_auth_cognito >=1.8.0 <1.9.0 1.8.0 1.8.0
amplify_core >=1.8.0 <1.9.0 1.8.0 1.8.0
amplify_flutter >=1.8.0 <1.9.0 1.8.0 1.8.0
amplify_push_notifications >=1.8.0 <1.9.0 1.8.0 1.8.0
amplify_secure_storage >=0.4.3 <0.5.0 0.4.3 0.4.3
flutter flutter 0.0.0 0.0.0
flutter_plugin_android_lifecycle ^2.0.9 2.0.19 2.0.19
Transitive dependencies
Package Constraint Compatible Latest
amplify_auth_cognito_dart - 0.10.13 0.10.13
amplify_db_common - 0.3.6 0.3.6
amplify_db_common_dart - 0.3.7 0.3.7
amplify_secure_storage_dart - 0.4.4 0.4.4
async - 2.11.0 2.11.0
aws_common - 0.6.4 0.6.4
aws_signature_v4 - 0.5.2 0.5.2
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crclib - 3.0.0 3.0.0
crypto - 3.0.3 3.0.3
device_info_plus - 10.1.0 10.1.0
device_info_plus_platform_interface - 7.0.0 7.0.0
drift - 2.14.1 2.17.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_web_plugins - 0.0.0 0.0.0
graphs - 2.3.1 2.3.1
http - 1.2.1 1.2.1
http2 - 2.3.0 2.3.0
http_parser - 4.0.2 4.0.2
intl - 0.19.0 0.19.0
js - 0.6.7 0.7.1
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
mime - 1.0.5 1.0.5
oauth2 - 2.0.2 2.0.2
os_detect - 2.0.1 2.0.1
package_info_plus - 6.0.0 7.0.0
package_info_plus_platform_interface - 2.0.1 3.0.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
retry - 3.1.2 3.1.2
shared_preferences - 2.2.3 2.2.3
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
shelf - 1.4.1 1.4.1
sky_engine - 0.0.99 0.0.99
smithy - 0.6.4 0.6.4
smithy_aws - 0.6.3 0.6.3
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
sqlite3 - 2.4.2 2.4.2
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
tuple - 2.0.2 2.0.2
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
win32_registry - 1.1.3 1.1.3
worker_bee - 0.2.4 0.2.4
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.