vyuh_feature_system 1.15.7 copy "vyuh_feature_system: ^1.15.7" to clipboard
vyuh_feature_system: ^1.15.7 copied to clipboard

Provides the essential building blocks for a CMS-driven UI

0
likes
120/ 160
pub points
80%
popularity

We analyzed this package 10 hours ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/vyuh-tech/vyuh/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

127 out of 810 API elements (15.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: accordion, accordion.Accordion, accordion.Accordion.Accordion, accordion.Accordion.contentBuilder, accordion.Accordion.description.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:vyuh_feature_system/vyuh_feature_system.dart that imports:
  • package:vyuh_feature_system/ui/content_image.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:vyuh_feature_system/vyuh_feature_system.dart that imports:
  • package:vyuh_feature_system/ui/content_image.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_object_provider.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `macOS`.

Because:

  • package:vyuh_feature_system/vyuh_feature_system.dart that imports:
  • package:vyuh_feature_system/content/index.dart that imports:
  • package:vyuh_feature_system/content/web_view.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:vyuh_feature_system/vyuh_feature_system.dart that imports:
  • package:vyuh_feature_system/ui/content_image.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cached_network_image ^3.3.1 3.3.1 3.3.1
collection ^1.18.0 1.18.0 1.19.0
flutter flutter 0.0.0 0.0.0
flutter_animate ^4.3.0 4.5.0 4.5.0
flutter_mobx ^2.2.0+2 2.2.1+1 2.2.1+1
flutter_sanity_portable_text ^1.3.0 1.3.4 1.3.4
go_router ^14.0.1 14.2.1 14.2.1
json_annotation ^4.9.0 4.9.0 4.9.0
json_path ^0.7.1 0.7.2 0.7.2
logger ^2.0.2+1 2.4.0 2.4.0
mobx ^2.3.0+1 2.3.3+2 2.3.3+2
nanoid ^1.0.0 1.0.0 1.0.0
smooth_page_indicator ^1.1.0 1.2.0 1.2.0
url_launcher ^6.3.0 6.3.0 6.3.0
vyuh_core ^1.11.1 1.11.1 1.11.1
vyuh_extension_content ^1.4.3 1.4.3 1.4.3
webview_flutter ^4.4.3 4.8.0 4.8.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
cached_network_image_platform_interface - 4.0.0 4.0.0
cached_network_image_web - 1.2.0 1.2.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_cache_manager - 3.3.2 3.3.2
flutter_shaders - 0.1.2 0.1.2
flutter_web_plugins - 0.0.0 0.0.0
get_it - 7.7.0 7.7.0
http - 1.2.2 1.2.2
http_parser - 4.0.2 4.1.0
iregexp - 0.1.2 0.1.2
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.12.0
maybe_just_nothing - 0.5.3 0.5.3
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
octo_image - 2.0.0 2.0.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.7 2.2.7
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
petitparser - 6.0.2 6.0.2
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
retry - 3.1.2 3.1.2
rfc_6901 - 0.2.0 0.2.0
rxdart - 0.27.7 0.28.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
sqflite - 2.3.3+1 2.3.3+1
sqflite_common - 2.5.4 2.5.4
string_scanner - 1.3.0 1.3.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
url_launcher_android - 6.3.4 6.3.4
url_launcher_ios - 6.3.1 6.3.1
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.2.0 2.3.1
url_launcher_windows - 3.1.1 3.1.1
uuid - 4.4.2 4.4.2
vector_math - 2.1.4 2.1.4
web - 1.0.0 1.0.0
webview_flutter_android - 3.16.4 3.16.4
webview_flutter_platform_interface - 2.10.0 2.10.0
webview_flutter_wkwebview - 3.14.0 3.14.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.