get_cli 1.4.5
get_cli: ^1.4.5 copied to clipboard

Official CLI for GetX™ framework to build Flutter and Server Applications easily

127
likes
70 / 110
pub points
81 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 119 out of 556 API elements (21.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:get_cli/get_cli.dart that imports:
  • package:get_cli/extensions.dart that imports:
  • package:get_cli/core/internationalization.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Use isNotEmpty instead of length

lib/common/utils/json_serialize/model_generator.dart:92:15

   ╷
92 │           if ((jsonRawData[dependency.name] as List).length > 0) {
   │               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/common/utils/json_serialize/model_generator.dart

lib/functions/routes/get_app_pages.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^1.0.21.1.12.0.1
archive^2.0.132.0.133.1.2
cli_dialog^0.3.30.3.30.4.0
cli_menu^0.2.20.2.30.2.3
dart_style>=1.0.10 <2.0.01.3.122.0.0
http^0.12.20.12.20.13.1
intl^0.16.10.16.10.17.0
json_ast^1.0.51.0.51.0.5
meta^1.2.31.3.01.3.0
path^1.7.01.8.01.8.0
process_run^0.11.2+10.11.2+80.12.1
recase^3.0.03.0.13.0.1
version^1.2.01.3.12.0.0
yaml^2.2.12.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.020.0.0
analyzer-0.41.21.4.0
args-1.6.02.0.0
async-2.5.02.5.0
charcode-1.2.01.2.0
cli_util-0.2.00.3.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
file-6.1.06.1.0
glob-2.0.12.0.1
grapheme_splitter-1.0.01.0.0
http_parser-3.1.44.0.0
io-1.0.01.0.0
package_config-1.9.32.0.0
pub_semver-2.0.02.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 9 issues. Showing the first 2:

The constraint `^1.0.2` on ansicolor does not support the stable version `2.0.1`, that was published 26 days ago.

When ansicolor is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions ansicolor to update the constraint.

The constraint `^2.0.13` on archive does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions archive to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

127
likes
70
pub points
81%
popularity

Publisher

getx.site

Official CLI for GetX™ framework to build Flutter and Server Applications easily

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

ansicolor, archive, cli_dialog, cli_menu, dart_style, http, intl, json_ast, meta, path, process_run, recase, version, yaml

More

Packages that depend on get_cli