get_cli 1.5.0
get_cli: ^1.5.0 copied to clipboard

Official CLI for GetX™ framework to build Flutter and Server Applications easily

Use this package as an executable

1. Install it

You can install the package from the command line:

$ dart pub global activate get_cli

Use it

The package has the following executables:

$ get
$ getx

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add get_cli

With Flutter:

 $ flutter pub add get_cli

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  get_cli: ^1.5.0

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:get_cli/get_cli.dart';
137
likes
90
pub points
82%
popularity

Publisher

getx.site

Official CLI for GetX™ framework to build Flutter and Server Applications easily

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

ansicolor, archive, cli_dialog, cli_menu, collection, dart_style, http, intl, meta, path, process_run, pubspec, recase, version, yaml

More

Packages that depend on get_cli