carp_firebase_backend 0.21.0
carp_firebase_backend: ^0.21.0 copied to clipboard

CARP Mobile Sensing data backend for uploading data to Google Firebase.

1
likes
80 / 130
pub points
32 %
popularity

We analyzed this package on Jun 24, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 59 out of 97 API elements (60.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:carp_firebase_backend/carp_firebase_backend.dart that imports:
  • package:carp_mobile_sensing/carp_mobile_sensing.dart that imports:
  • package:carp_mobile_sensing/sampling_packages/sensors/sensors.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/carp_firebase_backend.g.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
carp_mobile_sensing^0.21.00.21.60.21.6
cloud_firestore^0.14.00.14.42.2.2
firebase_auth^0.18.00.18.4+11.4.1
firebase_core^0.5.00.5.31.3.0
firebase_storage^5.2.05.2.08.1.3
flutterflutter0.0.00.0.0
google_sign_in^4.0.04.5.95.0.4
json_annotation^3.0.03.1.14.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.1.1
async-2.7.02.7.0
battery-1.0.112.0.3
battery_platform_interface-1.0.02.0.1
carp_core-0.21.50.21.5
characters-1.1.01.1.0
charcode-1.3.11.3.1
cloud_firestore_platform_interface-2.2.15.1.2
cloud_firestore_web-0.2.1+22.1.2
collection-1.15.01.15.0
convert-2.1.13.0.0
cron-0.2.40.3.0
crypto-2.1.53.0.1
device_apps-1.3.02.1.1
device_info-1.0.02.0.2
device_info_platform_interface-1.0.12.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
file_utils-1.0.01.0.0
firebase_auth_platform_interface-2.1.44.3.1
firebase_auth_web-0.3.2+31.3.1
firebase_core_platform_interface-2.1.04.0.1
firebase_core_web-0.2.1+11.1.0
firebase_storage_platform_interface-1.0.22.1.2
firebase_storage_web-0.1.1+11.1.2
flutter_web_plugins-0.0.00.0.0
globbing-1.0.01.0.0
google_sign_in_platform_interface-1.1.22.0.1
google_sign_in_web-0.9.20.10.0
http-0.12.20.13.3
http_parser-3.1.44.0.0
intl-0.16.10.17.0
js-0.6.30.6.3
light-2.1.02.1.0
matcher-0.12.100.12.10
meta-1.3.01.4.0
package_info-0.4.3+42.0.2
path-1.8.01.8.0
path_provider-1.6.282.0.2
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
pedantic-1.11.11.11.1
pedometer-2.1.03.0.0
permission_handler-5.1.0+28.1.1
permission_handler_platform_interface-2.0.23.6.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
quiver-2.1.53.0.1
screen_state-1.0.12.0.0
sensors-0.4.2+62.0.3
shared_preferences-0.5.12+42.0.6
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stats-1.0.12.0.0
string_scanner-1.1.01.1.0
system_info-1.0.01.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.4
vector_math-2.1.02.1.0
win32-2.2.42.2.4
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^0.14.0` on cloud_firestore does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

The constraint `^0.18.0` on firebase_auth does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions firebase_auth to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.