automated_testing_framework_plugin_flow_control 2.0.0
automated_testing_framework_plugin_flow_control: ^2.0.0 copied to clipboard

Flutter Android iOS

Library to use provide flow control test steps to the Automated Testing Framework.

0
likes
90 / 110
pub points
70 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 109 out of 281 API elements (38.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:automated_testing_framework_plugin_flow_control/automated_testing_framework_plugin_flow_control.dart that imports:
  • package:automated_testing_framework_plugin_flow_control/src/types/typedefs.dart that imports:
  • package:automated_testing_framework/automated_testing_framework.dart that imports:
  • package:automated_testing_framework/src/report/models/test_device_info_helper.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
automated_testing_framework^2.0.02.0.02.0.0
convert^2.1.12.1.13.0.0
flutterflutter0.0.00.0.0
flutter_typeahead^2.0.02.0.02.0.0
form_validation^1.0.2+11.0.2+11.0.2+1
json_class^1.0.7+21.0.7+21.0.7+2
logging>=0.11.4 <2.0.00.11.41.0.0
meta^1.2.41.3.0-nullsafety.31.3.0
static_translations^1.0.3+11.0.3+11.0.3+1
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.0.0
automated_testing_framework_models-1.1.01.1.0
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
child_builder-1.0.0+21.0.0+2
collection-1.15.0-nullsafety.31.15.0
crypto-2.1.53.0.0
device_info-1.0.02.0.0
device_info_platform_interface-1.0.12.0.0
flutter_keyboard_visibility-4.0.64.0.6
flutter_keyboard_visibility_platform_interface-1.0.11.0.1
flutter_keyboard_visibility_web-1.0.11.0.1
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.0
http_parser-3.1.44.0.0
intl-0.16.10.17.0
json_schema2-1.0.0+11.0.0+1
json_theme-1.5.0+21.5.0+2
matcher-0.12.90.12.10
nested-0.0.41.0.0
package_info-0.4.3+42.0.0
path-1.7.01.8.0
pedantic-1.9.21.10.0
pigment-1.0.31.0.3
plugin_platform_interface-1.0.32.0.0
pointycastle-2.0.12.0.1
provider-4.3.34.3.3
quiver-2.1.53.0.0
rest_client-1.0.6+21.0.6+2
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
tinycolor-1.0.31.0.3
typed_data-1.3.0-nullsafety.31.3.0
uri-0.11.41.0.0
uuid-2.2.23.0.0
vector_math-2.1.0-nullsafety.32.1.0
websafe_platform-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.1` on convert does not support the latest published version `3.0.0`

pubspec.yaml:12:12

   ╷
12 │   convert: ^2.1.1
   │            ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.