appwrite 12.0.4 copy "appwrite: ^12.0.4" to clipboard
appwrite: ^12.0.4 copied to clipboard

Appwrite is an open-source self-hosted backend server that abstract and simplify complex and repetitive development tasks behind a very simple REST API

526
likes
130/ 160
pub points
96%
popularity

We analyzed this package 20 hours ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

538 out of 734 API elements (73.3 %) have documentation comments.

Some symbols that are missing documentation: appwrite.Account.client, appwrite.AppwriteException.code, appwrite.AppwriteException.response, appwrite.Avatars.client, appwrite.Databases.client.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:appwrite/appwrite.dart that imports:
  • package:appwrite/src/realtime.dart that imports:
  • package:appwrite/src/client.dart that imports:
  • package:appwrite/src/client_io.dart that imports:
  • package:flutter_web_auth_2/flutter_web_auth_2.dart that imports:
  • package:flutter_web_auth_2/src/server.dart that imports:
  • package:window_to_front/window_to_front.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:appwrite/appwrite.dart that imports:
  • package:appwrite/src/realtime.dart that imports:
  • package:appwrite/src/client.dart that imports:
  • package:appwrite/src/client_io.dart that imports:
  • package:flutter_web_auth_2/flutter_web_auth_2.dart that imports:
  • package:flutter_web_auth_2/src/server.dart that imports:
  • package:window_to_front/window_to_front.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Linux`.

Because:

  • package:appwrite/appwrite.dart that imports:
  • package:appwrite/src/realtime.dart that imports:
  • package:appwrite/src/client.dart that imports:
  • package:appwrite/src/client_io.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:appwrite/appwrite.dart that imports:
  • package:appwrite/src/realtime.dart that imports:
  • package:appwrite/src/client.dart that imports:
  • package:appwrite/src/client_io.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package not compatible with platform Web

Because:

  • package:appwrite/appwrite.dart that imports:
  • package:appwrite/src/realtime.dart that imports:
  • package:appwrite/src/client.dart that imports:
  • package:appwrite/src/client_browser.dart that imports:
  • package:universal_html/html.dart that imports:
  • package:universal_html/src/_sdk/html.dart that imports:
  • package:universal_html/src/_sdk_html_additions.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The value of the field '_notifyDone' isn't used.

lib/src/realtime_mixin.dart:25:8

   ╷
25 │   bool _notifyDone = true;
   │        ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/realtime_mixin.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cookie_jar ^4.0.8 4.0.8 4.0.8
device_info_plus ^10.1.0 10.1.0 10.1.0
flutter flutter 0.0.0 0.0.0
flutter_web_auth_2 ^3.1.1 3.1.2 3.1.2
http >=0.13.6 <2.0.0 1.2.2 1.2.2
package_info_plus ^8.0.0 8.0.0 8.0.0
path_provider ^2.1.3 2.1.3 2.1.3
universal_html ^2.2.4 2.2.4 2.2.4
web_socket_channel ^2.4.5 2.4.5 3.0.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
charcode - 1.3.1 1.3.1
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
csslib - 1.0.0 1.0.0
device_info_plus_platform_interface - 7.0.0 7.0.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_auth_2_platform_interface - 3.1.0 3.1.0
flutter_web_plugins - 0.0.0 0.0.0
html - 0.15.4 0.15.4
http_parser - 4.0.2 4.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
package_info_plus_platform_interface - 3.0.0 3.0.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.7 2.2.7
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
universal_io - 2.2.2 2.2.2
url_launcher - 6.3.0 6.3.0
url_launcher_android - 6.3.5 6.3.5
url_launcher_ios - 6.3.1 6.3.1
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 1.0.0
win32 - 5.5.1 5.5.1
win32_registry - 1.1.3 1.1.3
window_to_front - 0.0.3 0.0.3
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.4.5` on web_socket_channel does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions web_socket_channel to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

526
likes
130
pub points
96%
popularity

Publisher

verified publisherappwrite.io

Appwrite is an open-source self-hosted backend server that abstract and simplify complex and repetitive development tasks behind a very simple REST API

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

BSD-3-Clause (license)

Dependencies

cookie_jar, device_info_plus, flutter, flutter_web_auth_2, http, package_info_plus, path_provider, universal_html, web_socket_channel

More

Packages that depend on appwrite