amplify_auth_cognito 1.6.0 icon indicating copy to clipboard operation
amplify_auth_cognito: ^1.6.0 copied to clipboard

The Amplify Flutter Auth category plugin using the AWS Cognito provider.

78
likes
120/ 140
pub points
98%
popularity

We analyzed this package 19 hours ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://docs.amplify.aws/lib/q/platform/flutter/ was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

OUT: Documenting amplify_auth_cognito... Discovering libraries... Linking elements... Precaching local docs for 947511 elements... ERR: warning: private API of package:amplify_auth_cognito_dart is reexported by libraries in other packages: from amplify_auth_cognito.FederateToIdentityPoolRequest: (file:///tmp/analyzerCGNBMO/pub-cache/hosted/20231128t115900-dot-dartlang-pub.appspot.com/amplify_auth_cognito_dart-0.10.7/lib/src/mod[...] referred to by amplify_auth_cognito: (file:///tmp/pana_OLZMYP/lib/amplify_auth_cognito.dart:5:9) warning: private API of package:amplify_core is reexported by libraries in other packages: from amplify_auth_cognito.UpdateUserAttributeOptions: (file:///tmp/analyzerCGNBMO/pub-cache/hosted/20231128t115900-dot-dartlang-pub.appspot.com/amplify_core-1.6.1/lib/src/types/auth/attribute[...] referred to by amplify_auth_cognito: (file:///tmp/pana_OLZMYP/lib/amplify_auth_cognito.dart:5:9) warning: private API of package:amplify_core is reexported by libraries in other packages: from amplify_auth_cognito.UpdateUserAttributeOptions.UpdateUserAttributeOptions: (file:///tmp/analyzerCGNBMO/pub-cache/hosted/20231128t115900-dot-dartlang-pub.appspot.com/amplify_core-1.6.1/l[...] referred to by amplify_auth_cognito: (file:///tmp/pana_OLZMYP/lib/amplify_auth_cognito.dart:5:9) warning: private API of package:amplify_auth_cognito_dart is reexported by libraries in other packages: [1233 more lines]

10/10 points: Package has an example

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:amplify_auth_cognito/amplify_auth_cognito.dart that imports:
  • package:amplify_auth_cognito/src/auth_plugin_impl.dart that imports:
  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/utils/file_key_value_store.dart that declares support for platforms: iOS, Windows, Linux, macOS, Web.
Package does not support platform `iOS`.

Because:

  • package:amplify_auth_cognito/amplify_auth_cognito.dart that imports:
  • package:amplify_auth_cognito/src/auth_plugin_impl.dart that imports:
  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/amplify_secure_storage_dart.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/platforms/amplify_secure_storage_windows.dart that imports:
  • package:amplify_secure_storage_dart/src/ffi/win32/data_protection.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:amplify_auth_cognito/amplify_auth_cognito.dart that imports:
  • package:amplify_auth_cognito/src/auth_plugin_impl.dart that imports:
  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/amplify_secure_storage_dart.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/platforms/amplify_secure_storage_windows.dart that imports:
  • package:amplify_secure_storage_dart/src/ffi/win32/data_protection.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:amplify_auth_cognito/amplify_auth_cognito.dart that imports:
  • package:amplify_auth_cognito/src/auth_plugin_impl.dart that imports:
  • package:amplify_secure_storage/amplify_secure_storage.dart that imports:
  • package:amplify_secure_storage/src/amplify_secure_storage.vm.dart that imports:
  • package:amplify_secure_storage_dart/amplify_secure_storage_dart.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.dart that imports:
  • package:amplify_secure_storage_dart/src/mixins/amplify_secure_storage_mixin.vm.dart that imports:
  • package:amplify_secure_storage_dart/src/platforms/amplify_secure_storage_windows.dart that imports:
  • package:amplify_secure_storage_dart/src/ffi/win32/data_protection.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package not compatible with platform Web

Because:

  • package:amplify_auth_cognito/amplify_auth_cognito.dart that imports:
  • package:amplify_auth_cognito/src/auth_plugin_impl.dart that imports:
  • package:amplify_auth_cognito/src/credentials/legacy_credential_provider_impl.dart that imports:
  • package:amplify_auth_cognito/src/credentials/legacy_credential_provider_ios.dart that imports:
  • package:amplify_flutter/amplify_flutter.dart that imports:
  • package:amplify_flutter/src/amplify_impl.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
50 / 50icon to trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
amplify_analytics_pinpoint >=1.6.0 <1.7.0 1.6.1 1.6.1
amplify_analytics_pinpoint_dart >=0.3.3 <0.4.0 0.3.4 0.3.4
amplify_auth_cognito_dart >=0.10.6 <0.11.0 0.10.7 0.10.7
amplify_core >=1.6.0 <1.7.0 1.6.1 1.6.1
amplify_flutter >=1.6.0 <1.7.0 1.6.0 1.6.0
amplify_secure_storage >=0.4.0+6 <0.5.0 0.4.0+6 0.4.0+6
async ^2.10.0 2.11.0 2.11.0
flutter flutter 0.0.0 0.0.0
meta ^1.7.0 1.10.0 1.11.0
path ^1.8.0 1.8.3 1.8.3
plugin_platform_interface ^2.0.0 2.1.7 2.1.7
Transitive dependencies
Package Constraint Compatible Latest
amplify_db_common - 0.3.3 0.3.3
amplify_db_common_dart - 0.3.3 0.3.3
amplify_secure_storage_dart - 0.4.1 0.4.1
aws_common - 0.6.1 0.6.1
aws_signature_v4 - 0.5.0 0.5.0
built_collection - 5.1.1 5.1.1
built_value - 8.6.3 8.8.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crclib - 3.0.0 3.0.0
crypto - 3.0.3 3.0.3
device_info_plus - 9.1.1 9.1.1
device_info_plus_platform_interface - 7.0.0 7.0.0
drift - 2.11.1 2.13.2
ffi - 2.1.0 2.1.0
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_web_plugins - 0.0.0 0.0.0
graphs - 2.3.1 2.3.1
http - 1.1.2 1.1.2
http2 - 2.2.0 2.2.0
http_parser - 4.0.2 4.0.2
intl - 0.18.1 0.18.1
js - 0.6.7 0.6.7
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.5.0 0.8.0
mime - 1.0.4 1.0.4
oauth2 - 2.0.2 2.0.2
os_detect - 2.0.1 2.0.1
package_info_plus - 4.2.0 5.0.1
package_info_plus_platform_interface - 2.0.1 2.0.1
path_provider - 2.1.1 2.1.1
path_provider_android - 2.2.1 2.2.1
path_provider_foundation - 2.3.1 2.3.1
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.1 2.1.1
path_provider_windows - 2.2.1 2.2.1
petitparser - 5.4.0 6.0.1
platform - 3.1.3 3.1.3
retry - 3.1.2 3.1.2
shelf - 1.4.1 1.4.1
sky_engine - 0.0.99 0.0.99
smithy - 0.6.1 0.6.1
smithy_aws - 0.6.0 0.6.0
source_span - 1.10.0 1.10.0
sqlite3 - 2.1.0 2.1.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
tuple - 2.0.2 2.0.2
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.2.1
vector_math - 2.1.4 2.1.4
web - 0.3.0 0.4.0
win32 - 5.1.0 5.1.0
win32_registry - 1.1.2 1.1.2
worker_bee - 0.2.1 0.2.1
xdg_directories - 1.0.3 1.0.3
xml - 6.3.0 6.4.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.21.43, Flutter 3.16.1, Dart 3.2.1.

Check the analysis log for details.