widget_toolkit_qr 0.0.2 copy "widget_toolkit_qr: ^0.0.2" to clipboard
widget_toolkit_qr: ^0.0.2 copied to clipboard

A Flutter package which provides a QR scanner widget easy integratable into the application.

7
likes
160/ 160
pub points
25%
popularity

We analyzed this package 6 hours ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

30 out of 94 API elements (31.9 %) have documentation comments.

Some symbols that are missing documentation: widget_toolkit_qr, widget_toolkit_qr.QrScannerBloc, widget_toolkit_qr.QrScannerBloc.QrScannerBloc, widget_toolkit_qr.QrScannerBloc.events, widget_toolkit_qr.QrScannerBloc.states.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:widget_toolkit_qr/widget_toolkit_qr.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/di/qr_scanner_widget.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/views/qr_scanner_component.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/blocs/qr_scanner_bloc.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/services/system_permissions_service.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/repositories/system_permissions_repository.dart that imports:
  • package:app_settings/app_settings.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:widget_toolkit_qr/widget_toolkit_qr.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/di/qr_scanner_widget.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/views/qr_scanner_component.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/blocs/qr_scanner_bloc.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/services/system_permissions_service.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/repositories/system_permissions_repository.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows, Web.
Package does not support platform `macOS`.

Because:

  • package:widget_toolkit_qr/widget_toolkit_qr.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/di/qr_scanner_widget.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/views/qr_scanner_component.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/blocs/qr_scanner_bloc.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/services/system_permissions_service.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/repositories/system_permissions_repository.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows, Web.
Package does not support platform `Web`.

Because:

  • package:widget_toolkit_qr/widget_toolkit_qr.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/di/qr_scanner_widget.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/views/qr_scanner_component.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/blocs/qr_scanner_bloc.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/services/system_permissions_service.dart that imports:
  • package:widget_toolkit_qr/src/lib_qr_scanner/repositories/system_permissions_repository.dart that imports:
  • package:app_settings/app_settings.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
app_settings ^5.0.0 5.1.1 5.1.1
flutter flutter 0.0.0 0.0.0
flutter_localizations flutter 0.0.0 0.0.0
flutter_qr_bar_scanner ^3.0.2 3.0.2 3.0.2
flutter_rx_bloc ^6.0.0 6.1.1 6.1.1
flutter_svg ^2.0.7 2.0.10+1 2.0.10+1
permission_handler ^11.0.0 11.3.1 11.3.1
provider ^6.0.5 6.1.2 6.1.2
rx_bloc ^5.0.0 5.0.3 5.0.3
rxdart ^0.27.7 0.27.7 0.28.0
theme_tailor_annotation ^3.0.0 3.0.1 3.0.1
widget_toolkit ^0.0.2 0.0.2 0.0.2
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
copy_with_extension - 5.0.4 5.0.4
equatable - 2.0.5 2.0.5
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.1.0
intl - 0.19.0 0.19.0
json_annotation - 4.9.0 4.9.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
native_device_orientation - 1.2.1 2.0.3
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
path_parsing - 1.0.1 1.0.1
permission_handler_android - 12.0.7 12.0.7
permission_handler_apple - 9.4.5 9.4.5
permission_handler_html - 0.1.1 0.1.1
permission_handler_platform_interface - 4.2.1 4.2.1
permission_handler_windows - 0.2.1 0.2.1
petitparser - 6.0.2 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
shimmer - 3.0.0 3.0.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
url_launcher - 6.3.0 6.3.0
url_launcher_android - 6.3.3 6.3.3
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_graphics - 1.1.11+1 1.1.11+1
vector_graphics_codec - 1.1.11+1 1.1.11+1
vector_graphics_compiler - 1.1.11+1 1.1.11+1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.27.7` on rxdart does not support the stable version `0.28.0`, that was published 3 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.