shimmer 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 99

Shimmer #

pub package

A package provides an easy way to add shimmer effect in Flutter project

How to use #

import 'package:shimmer/shimmer.dart';

SizedBox(
  width: 200.0,
  height: 100.0,
  child: Shimmer.fromColors(
    baseColor: Colors.red,
    highlightColor: Colors.yellow,
    child: Text(
      'Shimmer',
      textAlign: TextAlign.center,
      style: TextStyle(
        fontSize: 40.0,
        fontWeight:
        FontWeight.bold,
      ),
    ),
  ),
);

[1.0.1] - 2019-09-15

  • support stop and resume animation

[1.0.0] - 2019-01-06

  • support animation loop control
  • the package is stable enough to reach v1.0.0 now

[0.0.6] - 2018-11-14

  • add code document

[0.0.5] - 2018-08-10

  • re-config to support Dart2

[0.0.4] - 2018-06-20

  • update metadata

[0.0.3] - 2018-06-07

  • add direction property to allow customizing animation direction
  • BREAKING: define a new default constructor to allow customizing gradient pattern, the old default construct is renamed to Shimmer.fromColors

[0.0.2] - 2018-06-07

  • update metadata

[0.0.1] - 2018-06-06

  • Initial release.

example/README.md

example #

A new Flutter project.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  shimmer: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:shimmer/shimmer.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
98
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
99
Learn more about scoring.

We analyzed this package on Oct 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test