upgrader 3.2.0
upgrader: ^3.2.0 copied to clipboard

Flutter package for prompting users to upgrade when there is a newer version of the app in the store.

273
likes
120 / 130
pub points
94 %
popularity

We analyzed this package on Apr 12, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 112 out of 205 API elements (54.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:upgrader/upgrader.dart that imports:
  • package:upgrader/src/upgrader.dart that imports:
  • package:upgrader/src/appcast.dart that imports:
  • package:device_info/device_info.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
device_info^2.0.02.0.02.0.0
flutterflutter0.0.00.0.0
http^0.13.00.13.10.13.1
package_info^2.0.02.0.02.0.0
shared_preferences^2.0.32.0.52.0.5
url_launcher^6.0.26.0.36.0.3
version^2.0.02.0.02.0.0
xml^5.0.25.1.05.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
device_info_platform_interface-2.0.12.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_web_plugins-0.0.00.0.0
http_parser-4.0.04.0.0
js-0.6.30.6.3
meta-1.3.01.3.0
path-1.8.01.8.0
path_provider_linux-2.0.02.0.0
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.02.0.0
petitparser-4.1.04.1.0
platform-3.0.03.0.0
plugin_platform_interface-2.0.02.0.0
process-4.2.14.2.1
shared_preferences_linux-2.0.02.0.0
shared_preferences_macos-2.0.02.0.0
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.02.0.0
shared_preferences_windows-2.0.02.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_linux-2.0.02.0.0
url_launcher_macos-2.0.02.0.0
url_launcher_platform_interface-2.0.22.0.2
url_launcher_web-2.0.02.0.0
url_launcher_windows-2.0.02.0.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.2.00.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

273
likes
120
pub points
94%
popularity

Publisher

larryaasen.com

Flutter package for prompting users to upgrade when there is a newer version of the app in the store.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

device_info, flutter, http, package_info, shared_preferences, url_launcher, version, xml

More

Packages that depend on upgrader